Can't install latest CU through Windows Update after integrating the previous one and the latest SSU and removing and integrating some things

I'm having the 0x800f0982 WU error again for some months in 3 PCs. I even ran the 1909's setup.exe and I have it again (I had used an untouched 1903 image to do a clean install). It looks like I'll have to do a clean install again (I can't do it in the other 2 PCs) but who can guarantee me I won't have it in the future at least one more time?
 
Last edited:

nuhi

NTLite developer
Staff member
I'm having the 0x800f0982 WU error again for some months in 3 PCs. I even ran the 1909's setup.exe and I have it again (I had used an untouched 1903 image to do a clean install). It looks like I'll have to do a clean install again (I can't do it in the other 2 PCs) but who can guarantee me I won't have it in the future at least one more time?
If you replicate any issue with a preset using the latest version + CU, let me know how to see the issue.
Without clear steps to replicate the issue, it's just guessing what is the actual cause.
Also make sure not to use any other tool package removals when evaluating NTLite's, including NTLite's new package removal in the beta (as it uses DISM).
 
If you replicate any issue with a preset using the latest version + CU, let me know how to see the issue.
Without clear steps to replicate the issue, it's just guessing what is the actual cause.
Also make sure not to use any other tool package removals when evaluating NTLite's, including NTLite's new package removal in the beta (as it uses DISM).
I have it even with an untouched image after doing a clean install. I don't use beta releases but you said you wanted to make NTLite compatible with other tools like MSMG TooolKit.

EDIT: I did a clean install and now I have this 0x800f0982 WU error again.

EDIT 2: I finally fixed the problem (at least for now)! I did what this user said, ignored his/her notice, downloaded Farbar Recovery Scan Tool x64 and the user's fixlist.txt file, extracted both to the desktop, ran Farbar Recovery Scan Tool x64 as administrator, clicked on "Fix" (which creates a Fixlog.txt file on the Farbar Recovery Scan Tool x64 and fixlist.txt's directory) and after the process completed I successfully installed the CU! Maybe I'll have to do this again on this install (and maybe on other ones too) later.

Both fixlist.txt and Fixlog.txt files mentions some "PPI Projection" registry keys which apparently are related to the Connect app. I've been removing the Connect app with this. Do you think this is causing the problem?

EDIT 3: I just tested this tool on a clean install and it really is the cause of this problem. Is there a way of removing the Connect app (on a live install) without using this tool and without causing this problem?
 
Last edited:

nuhi

NTLite developer
Staff member
EDIT 3: I just tested this tool on a clean install and it really is the cause of this problem. Is there a way of removing the Connect app (on a live install) without using this tool and without causing this problem?
There is a ppiprojection (Microsoft.ppiprojection) app in NTLite if detected on the system, other than that there is a Network Projection component as well.
Can't comment on other tool's removal methods as I didn't review them, let me know if you see any NTLite issues.
 
There is a ppiprojection (Microsoft.ppiprojection) app in NTLite if detected on the system, other than that there is a Network Projection component as well.
Can't comment on other tool's removal methods as I didn't review them, let me know if you see any NTLite issues.
Well, but I don't have a paid license to remove it on a live install with NTLite... W10Privacy removes apps on a live install, including system ones, but after removing its "OneConnect" app it still shows up, which is weird (it doesn't even show up on CCleaner and Revo Uninstaller and I can't remove it the "normal" way [the first thing I tried], obviously, and with Windows 10 Store Apps Cleaner). So, if I remove the Connect app with NTLite the Network Projection component will also be removed?

EDIT: I removed the Connect app with NTLite and I didn't have the WU error.
 
Last edited:
Top