Error Integrating KB4524244 (Pulled)

SHO_GuN

New Member
I get the error in the screenshot below when I try to integrate KB4524244.

Seems to be an order thing. I *think* KB4532691 and KB4523204 have to be integrated first, maybe more. At any rate, if I run my normal settings then integrate KB4524244 afterwards all is OK.

Snap1.jpg


Edit: After messing with this some more I have decided all is not OK as I said above. If I run my normal settings then let WU install KB4524244 all is OK, if I do a second NTLite run and integrate it WU takes a very long time to check for updates. Its a tiny update and only takes a couple seconds to download so I will just let WU handle it. There may be a forthcoming KB that supercedes both KB4524244 and KB4523204 anyway.
 
Last edited:

nuhi

NTLite developer
Staff member
SHO_GuN, thanks for the feedback, as far as I get it from the screenshot, you're saying that KB4524244 locks feature config?
Have you confirmed it, on a full ISO, without removing anything, just add KB4524244 and then reload and try to enable/disable those features?
You know you can delay-install desired updates by adding them to the Post-setup page, so you don't have to wait for WU to get safer.
Will try as soon as possible and give my feedback as well.

ege914, that's true if integrating/configuring features after deep removals. But lately with WU compatibility even that should work.
Still it is best to use one preset on an original ISO, then edit that preset instead of reediting the image. This goes as recommended in general when it comes to package configuration of Windows images, as certain combinations can add many pending changes (not full integration until first boot).
 

SHO_GuN

New Member
Have you confirmed it, on a full ISO, without removing anything, just add KB4524244 and then reload and try to enable/disable those features?
I just did - KB4524244 integrated without complaint, reloaded and the features enabled/disabled OK and NTLite again ran without complaint.
 

SHO_GuN

New Member
Found the culprit. NETFX3 + KB4524244 + Direct Play & SMB = error in OP.

Take NETFX3 out and it runs fine.
 
Top