IP Static and DNS

tistou77

Member
Hello

I saw that it was possible to add the static IP (ipv4 or ipv6) and the DNS 1 and 2 in the autounattend file
Anyone know how to do it ?

Thanks
 

tistou77

Member
Hi

I had seen this page, but I do not know at all where to put this information in the file and which used for the IP and DNS :)
 

tistou77

Member
I was helped and tested with this code

Code:
<component name="Microsoft-Windows-TCPIP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <Interfaces>
                <Interface wcm:action="add">
                    <Ipv4Settings>
                        <DhcpEnabled>false</DhcpEnabled>
                        <Metric>20</Metric>
                        <RouterDiscoveryEnabled>true</RouterDiscoveryEnabled>
                    </Ipv4Settings>
                    <Identifier>Ethernet</Identifier>
                    <UnicastIpAddresses>
                        <IpAddress wcm:action="add" wcm:keyValue="1">192.168.0.1/24</IpAddress>
                    </UnicastIpAddresses>
                    <Routes>
                        <Route wcm:action="add">
                            <Identifier>1</Identifier>
                            <Metric>10</Metric>
                            <NextHopAddress>192.168.0.254</NextHopAddress>
                            <Prefix>0.0.0.0/0</Prefix>
                        </Route>
                    </Routes>
                </Interface>
            </Interfaces>
        </component>
        <component name="Microsoft-Windows-DNS-Client" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <Interfaces>
                <Interface wcm:action="add">
                    <Identifier>Ethernet</Identifier>
                    <DNSServerSearchOrder>
                        <IpAddress wcm:action="add" wcm:keyValue="1">212.27.40.241</IpAddress>
                        <IpAddress wcm:action="add" wcm:keyValue="2">212.27.40.240</IpAddress>
                    </DNSServerSearchOrder>
                    <DisableDynamicUpdate>false</DisableDynamicUpdate>
                </Interface>
            </Interfaces>
        </component>
It works for everything except DNS, you have an idea why my PC, it does not work and it works in others ?
I do not think it's related to a setting of NTLite, the PC is not "plugged in" to the Internet during Windows installation

Thanks
 

Kasual

Well-Known Member
What i can think of, is another component removed or what about ethernet drivers installation? are installed on setup?
 

tistou77

Member
Many components removed with NTLite (including DHCP), ethernet driver (Intel) integrated with NTLite
No problem to manually set the IP, DNS after installing Windows
 
Top