NTLite Image Failure

Hellbovine

Active Member
I will update the original post in this thread if it becomes popular, so that it serves as a guide that we can direct people to. But for now I just have a quick question...

Is there a list of known issues that prevent Windows Setup from installing Windows?

I just started importing services registry keys into my image and it's the first time my installs were met with a Windows Setup blue screen error saying "Why did my PC restart?"

It's a pain in the ass trying to figure out which one(s) are the culprit so I'm basically sitting here reinstalling Windows over and over, eliminating a few services at a time until it installs successfully.

The services I narrowed it down to at the moment are these:
- mpssvc (Windows Defender Firewall)
- WdNisSvc (Microsoft Defender Antivirus Network Inspection Service)
- WinDefend (Microsoft Defender Antivirus Service)
- wscsvc (Security Center)
- SecurityHealthService (Windows Security Service)

Eventually I'll figure it out myself, but it's gonna waste a few hours time. Maybe someone else already knows? I tried searching the forum, but so far I haven't had a lot of luck because the search filters out keywords that are 3 letters or less, which is the majority of things like "Why" "Did" "My" "PC" "Restart" lol.

I'm on Windows 10 21H2.

Once it gets figured out I'll come back and update this and just start adding more and more things that prevent an install as I come across them.
 
Last edited:

garlin

Moderator
Staff member
Where do your reg keys get imported? Integrated in the image, or Post-Setup? Timing is everything, some features may not like being restricted by a pre-existing reg key before they run for the first time.
 

Hellbovine

Active Member
Into the image. Windows Setup finishes the install, but once it reaches the stage where it's "configuring services" it does its thing and restarts the PC, and then comes up with the blue screen. I imagine that it must be trying to 'start' some of these services during that phase, and when they fail to start it gives the error.

Once I figure out which specific key is the problem I'll try changing it from disabled to manual to test that theory, and then if that still doesn't work then I'll move the key to the post-setup.
 
Top