Reg settings not applying

xy44

New Member
Hi All, new NTLite user here :)

I'm using the free version for now as I trial the product but the one thing I am having an issue with is my registry settings are not applying with the ISO NTLite creates. If I run the .reg file on my Windows install afterwards it does what I want it to do but it doesn't apply during the install so is there something I am doing wrong?

Thanks!
 

ege914

Active Member
I think these settings won't be applied before useraccount is created. thats why you are having a problem. instead of adding them as registery entry you can use setupcomplete to apply them after account is created... nuhi can answer better
 
Last edited:

nuhi

NTLite developer
Staff member
Sure! File attached.
Thanks, as ege914 stated, please move this particular REG to the Post-setup, to delay its applying.
Because Windows during setup might redeploy these settings.

I now tried the reg with NTLite on an image and it applied correctly, you can look at the changes in Integrate - Registry - Hives on the right by reloading the edited image (right-click Software hive and choose Edit, then find in Regedit relative position to confirm removal of the key).
Now how will Windows deploy it and what it will reset, is outside the scope of reg applying. That is why you can delay it in Post-setup.

slimzky, if the same doesn't explain your issue, please attach the reg and tell me what wasn't applied?

Thanks.
 

xy44

New Member
Thanks, that worked! I have moved the reg file to the post setup.

My next question is, I configured Start Menu under settings to not show any folders except settings as follows:

1593618010109.png

But after I have finished installing Windows with my custom ISO, My Pictures and Documents still shows on the start menu:

1593619868306.png

How can I stop these showing?

Also, how can I configure File Explorer to go from looking like this after the install:

1593620013364.png

To this:

1593620048995.png

So I'm trying to have the ribbon expanded (rather than collapsed) and to have "This PC" and the C: drive expanded by default (rather than collapsed).

Thanks!
 

ege914

Active Member
they all have reg files that u can add to post setup. i use tenforums website to get those reg files
 

xy44

New Member
But the removing of the downloads and pictures on the start menu in NTLite isn't working even though I have disabled it (see screenshot)
 

ege914

Active Member
nuhi can check it quickly, i always apply reg files so i didn't even had chance to see if ntlite worked or not
 

slimzky

New Member
I agree that the Start Menu Folder tweak never worked for me. I enabled Downloads, File Explorer and Music but it won't show once OS is installed.
 

xy44

New Member
Can anyone help with hiding the Pictures and Downloads on the Start Menu? I can't even find where to do it in a registry file, is this even an option?
 

slimzky

New Member
Can anyone help with hiding the Pictures and Downloads on the Start Menu? I can't even find where to do it in a registry file, is this even an option?
i am not so sure if there is a reg tweak for that. afaik, activation is required in order to manually change taskbar/start menu settings.

in my case i activate manually so i think that is the issue.
 

ege914

Active Member

Clanger

Well-Known Member
ege914 RegFromApp is bloody great but might have problems sniffing settings app, especially if its full screen. might be better off sniffing Winaero Tweaker if it has the required tweaks.
 

xy44

New Member
I am trying to hide the bluetooth icon in the system tray post setup with a batch file with this:

REG ADD "HKCU\Control Panel\Bluetooth" /V "Notification Area Icon" /T REG_DWORD /D 00000000 /F
taskkill /f /im explorer.exe
start explorer.exe


But it doesn't work, any ideas how I can do this successfully?
 

Kasual

Well-Known Member
I am trying to hide the bluetooth icon in the system tray post setup with a batch file with this:

REG ADD "HKCU\Control Panel\Bluetooth" /V "Notification Area Icon" /T REG_DWORD /D 00000000 /F
The quotes probably, type in command line:
reg add /?

There is no need to add "start" in batch files.
 

xy44

New Member
The batch file works just fine if I run it manually and the bluetooth icon is removed but how do I get the batch file to run correctly with NTLite?
 
Top