Some problems about windows update

ege914

Active Member
since latest build came up. my old iso file started having some problems after first time updating windows. i know its stupid but it is... it takes ages to check for updates and

after first windows update, my os fails to check for updates or fails to download the latest kb update.. idk what happened :/

here is some bat and reg files i apply to my os after fresh install (they are part of a tweak software i made. but you don't need whole software to check the codes so i share only bat and reg files)

i'm sharing those files because maybe the problem is a simple code about windows update (i don't think there is codes for it but... because i deleted them and retested it) that makes wu fail to check or download. if anyone could check those files and help me out it would be great... please let me know if you see anything suspicious.

my system is windows 10 enterpriseS ltsb 2016

(i can share the software too if u want)
 

Kasual

Well-Known Member
For the bat 'Kokteyl Updates' you can remove everything related to gwx as it has expired the "free upgrade offer" since july 29 last year i think, after that date, Ms started delivering updates to remove gwx.

did you called "Administrator" to the machine?

"wmic computersystem where name="%computername%" call rename name="Administrator"

There are many tweaks that can be applied by NTLite in Tweaks - Services, - Machine, - User.

For the WU issue, no idea.
 

ege914

Active Member
Yes but this tweak software is designed to make every computer similar to each other, and tweaking them for performance and maintaince. so i will keep it. it is for all machines with ot without made by ntlite...

thanks for reply. as i said there is no wu update. i think it may be related to my preset or microsoft updates are in sort of bug.
 

nuhi

NTLite developer
Staff member
@ege914, regarding NTLite preset, I recommend to integrate the latest cumulative available when making an ISO.
Because for removals it is best to start with an update, that way next cumulative will apply only the difference and there is a lot less chance of anything going wrong.
There is no benefit in not integrating an update, as far as I can see.
While at it, make sure to use the latest version of the tool, was updated yesterday.

If you insist on installing full updates on reinstall, then please describe one of the issues that is easy to spot and tell me which cumulative to install. I'm guessing last months, then try to detect and install this months after applying this preset?
 

ege914

Active Member
but every cu update is independent to previous one? so i don't want to integrate an old update to my iso. thats why i use it vanilla then update it when every i use it... thats why i want no trouble with wu. but i think i will always have some trouble if i ever delete anything from my iso :/

last time i thought i am bug free but now there is this interesting issue that allows me to update my computer only 1 time.. after that it fails all the time.. maybe it is because of what it's installing (maybe last cu is causing this)
 
but every cu update is independent to previous one? so i don't want to integrate an old update to my iso
I would suggest using the tool WHDownloader as this tool will make sure all the proper updates are locally stored and all superseded updates will be "removed from the updates folder" but they will be still stored in the "superseded" folder so they will always be available for you. (this should solve the Cumulative Updates problem for you).

This way I keep track off all updates regarding my Windows / Office ISO's.

If I then want to "play" with NTLite I can make sure that the vanilla ISO will be brought up to date, before I start tinkering with the many option / settings this tool provides me :).
I have run into similar problems you are describing, but this was mainly caused by removing (in my opinion unnecessary) components, in trying to "cook" a small footprint Base install
But NTLite warns you that it could break installations (and I experienced only CU Monthly Security update problems, all other updates ran fine)
 

ege914

Active Member
İf anyone wants to test i use enterpriseS ltsb 1607 2016

And test this way
İnstall iso, after seing desktop run wu and install updates

Then restart and you need new updates to see the error. So you can try to enable net3.5 from features or install office and check for its updates
 

ege914

Active Member
"EnterpriseS LTSB" is the name

edit: right now i created a vm. updated it via wu. and now i will copy that vm multiple times and do different tests untill i find out the issue.

i'm guessing that one of my tweaks are causing this.. we will see.
 
Last edited:

ege914

Active Member
yeah as i thought one of my tweak codes are causing the wu bug + features page to fail to download 3.5...

i will pin point the code now..
 

ege914

Active Member
I found the issue...
it was "delivery optimization service"

I was using these codes to disable and delete it

sc config DoSvc start= disabled
sc stop DoSvc
sc delete DoSvc

the problem was the bold (last) line

so it seems that you can disable the service. but you should NOT delete it... or else the entire windows update and related things such as features page etc. will fail to download anything.

edit: here is reg fix for sc delete, windopws update problems......


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DoSvc]
"ServiceDll"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,\
00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
64,00,6f,00,73,00,76,00,63,00,2e,00,64,00,6c,00,6c,00,00,00
"ServiceDllUnloadOnStop"=dword:00000001
"DisplayName"="@%systemroot%\\system32\\dosvc.dll,-100"
"ErrorControl"=dword:00000001
"ImagePath"=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,\
74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
00,76,00,63,00,68,00,6f,00,73,00,74,00,2e,00,65,00,78,00,65,00,20,00,2d,00,\
6b,00,20,00,6e,00,65,00,74,00,73,00,76,00,63,00,73,00,00,00
"Start"=dword:00000004
"Type"=dword:00000020
"Description"="@%systemroot%\\system32\\dosvc.dll,-101"
"DependOnService"=hex(7):72,00,70,00,63,00,73,00,73,00,00,00,00,00
"ObjectName"="LocalSystem"
"ServiceSidType"=dword:00000001
"RequiredPrivileges"=hex(7):53,00,65,00,43,00,72,00,65,00,61,00,74,00,65,00,47,\
00,6c,00,6f,00,62,00,61,00,6c,00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,\
67,00,65,00,00,00,53,00,65,00,43,00,72,00,65,00,61,00,74,00,65,00,50,00,61,\
00,67,00,65,00,46,00,69,00,6c,00,65,00,50,00,72,00,69,00,76,00,69,00,6c,00,\
65,00,67,00,65,00,00,00,53,00,65,00,54,00,63,00,62,00,50,00,72,00,69,00,76,\
00,69,00,6c,00,65,00,67,00,65,00,00,00,53,00,65,00,43,00,68,00,61,00,6e,00,\
67,00,65,00,4e,00,6f,00,74,00,69,00,66,00,79,00,50,00,72,00,69,00,76,00,69,\
00,6c,00,65,00,67,00,65,00,00,00,53,00,65,00,41,00,73,00,73,00,69,00,67,00,\
6e,00,50,00,72,00,69,00,6d,00,61,00,72,00,79,00,54,00,6f,00,6b,00,65,00,6e,\
00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,67,00,65,00,00,00,53,00,65,00,\
49,00,6d,00,70,00,65,00,72,00,73,00,6f,00,6e,00,61,00,74,00,65,00,50,00,72,\
00,69,00,76,00,69,00,6c,00,65,00,67,00,65,00,00,00,53,00,65,00,49,00,6e,00,\
63,00,72,00,65,00,61,00,73,00,65,00,51,00,75,00,6f,00,74,00,61,00,50,00,72,\
00,69,00,76,00,69,00,6c,00,65,00,67,00,65,00,00,00,00,00
"DelayedAutoStart"=dword:00000000
"FailureActions"=hex:80,51,01,00,00,00,00,00,00,00,00,00,03,00,00,00,14,00,00,\
00,01,00,00,00,60,ea,00,00,01,00,00,00,60,ea,00,00,00,00,00,00,00,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DoSvc\Security]
"Security"=hex:01,00,14,80,78,00,00,00,84,00,00,00,14,00,00,00,30,00,00,00,02,\
00,1c,00,01,00,00,00,02,80,14,00,ff,00,0f,00,01,01,00,00,00,00,00,01,00,00,\
00,00,02,00,48,00,03,00,00,00,00,00,14,00,9d,00,02,00,01,01,00,00,00,00,00,\
05,0b,00,00,00,00,00,18,00,ff,01,0f,00,01,02,00,00,00,00,00,05,20,00,00,00,\
20,02,00,00,00,00,14,00,ff,01,0f,00,01,01,00,00,00,00,00,05,12,00,00,00,01,\
01,00,00,00,00,00,05,12,00,00,00,01,01,00,00,00,00,00,05,12,00,00,00
 
Last edited:

Kasual

Well-Known Member
"EnterpriseS LTSB" is the name
Found an Evaluation version only and is Enterprise S, seems like the label editions doesn't allow spaces.

I found the issue...
it was "delivery optimization service"

I was using these codes to disable and delete it

sc config DoSvc start= disabled
sc stop DoSvc
sc delete DoSvc

the problem was the bold (last) line

so it seems that you can disable the service. but you should NOT delete it... or else the entire windows update and related things such as features page etc. will fail to download anything.
i'm glad you found the issue, thanks for sharing.
 
Top