Start Menu Icons + Onedrive + WU Problems

ege914

Active Member
"Pre-installed apps" - disable
"Automatically install suggested apps"- disable
"Pre-installed OEM apps"- disable

are already disabled and + onedrive is disabled too i still get onedrive installation and all other office(including onenote icon) + edge + store icons on start menu at windows 10 home-pro x64-x86 tr 1903.

plus now windows updates fails on updates too (i even did not erase anything and enabled windows update compatibility protection.) kb4497935 error 0x800f0988 (maybe other updates are failing too but i can't know since i integrated some of the updates)


also these 3 screenshots says everything... and my preset is here https://files.fm/u/p9fa6j4w
 
Last edited:

nuhi

NTLite developer
Staff member
Thanks, but I'm a bit confused.
Are there two issues, one is OneDrive not being removed with the attached preset and the second is Windows bug where Windows Update does not work even if nothing is removed?

Downloading Turkish ISO to try the OneDrive preset.
 

ege914

Active Member
Thanks, but I'm a bit confused.
Are there two issues, one is OneDrive not being removed with the attached preset and the second is Windows bug where Windows Update does not work even if nothing is removed?

Downloading Turkish ISO to try the OneDrive preset.

yes and 3rd problem is that i see icons at start menu even i disabled these;

"Pre-installed apps" - disable
"Automatically install suggested apps"- disable
"Pre-installed OEM apps"- disable

shown icons are: word, excel, powerpoint, onenote, outlook, windows store, edge, onedrive



btw: i think these problems only occured on iso's that i integrated some of the updates and netfx3.5(via ntlite's template)
 
Last edited:

nuhi

NTLite developer
Staff member
OK, installed Turkish ISO with your preset.

1. OneDrive is just disabled, not removed, but yeah it's still in the tray, that seems is how it works.
To see more about the policy, check gpedit.msc,
Computer Configuration > Administrative Templates > Windows Components > OneDrive
Prevent File System option.

Even if not shown set in the UI, what it sets is:

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\OneDrive, DisableFileSyncNGSC 1

And it was set.
Remove OneDrive if you want it fully gone.


2. WU not working even if not removing anything. That sounds like a setting dependency or a Windows issue.
Regardless, you can attach a compressed c:\windows\logs\cbs\cbs.log at the moment of the issue for review.


3. Those links are not apps or Store links, they are literally just web links to online Word, Outlook etc. Maybe there is a separate tweak to disable those, or edit start menu option should be added, either way it's not a bug.
 

ege914

Active Member
OK, installed Turkish ISO with your preset.

1. OneDrive is just disabled, not removed, but yeah it's still in the tray, that seems is how it works.
To see more about the policy, check gpedit.msc,
Computer Configuration > Administrative Templates > Windows Components > OneDrive
Prevent File System option.

Even if not shown set in the UI, what it sets is:

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\OneDrive, DisableFileSyncNGSC 1

And it was set.
Remove OneDrive if you want it fully gone.


2. WU not working even if not removing anything. That sounds like a setting dependency or a Windows issue.
Regardless, you can attach a compressed c:\windows\logs\cbs\cbs.log at the moment of the issue for review.


3. Those links are not apps or Store links, they are literally just web links to online Word, Outlook etc. Maybe there is a separate tweak to disable those, or edit start menu option should be added, either way it's not a bug.

thank you for checking them all for me;

1) can you add an option to clean leftovers which deletes onedrive setup files and icons (office, onedrive, store, edge) ?

2) cbs is attached (if you can install my edited iso to vm you can see problem at your own machine)

3) i can't delete icons from startmenu via del command etc because they are not in a folder. i can't find their real locations.
 

Attachments

nuhi

NTLite developer
Staff member
thank you for checking them all for me;

1) can you add an option to clean leftovers which deletes onedrive setup files and icons (office, onedrive, store, edge) ?

2) cbs is attached (if you can install my edited iso to vm you can see problem at your own machine)

3) i can't delete icons from startmenu via del command etc because they are not in a folder. i can't find their real locations.
1) That's called a onedrive component removal :) Why not use it, I don't get it.
2) No errors inside it, are you sure it is the exact one? What error do you see when that CBS was generated, 0x800f0988 ?
3) Yeah, MS baked them into the default start menu layout, as said it would require an editor.
 

ege914

Active Member
1) That's called a onedrive component removal :) Why not use it, I don't get it.
2) No errors inside it, are you sure it is the exact one? What error do you see when that CBS was generated, 0x800f0988 ?
3) Yeah, MS baked them into the default start menu layout, as said it would require an editor.
1) i thought i used it it is my bad so sorry.
2) yes thats the error code. i install this iso to 3 of my computers. they are all same. it is iso related problem. you can only test it by installing that edited iso to your system! and try to update it. or else ntlite will always have that bug. because i can't expain anything further about it.
3) yes we all hope you do that editor., as my research shows u can import a default layout via powershell. maybe ntlite can have an empty layout for us

the only problem is that idk if it permanantly locks startmenu. if it locks it then its not handy
 
Last edited:

ege914

Active Member
nuhi here is new cbs, i cleared previous one and tried to update windows 2-3 times to generate new logs. maybe this helps more
 

Attachments

nuhi

NTLite developer
Staff member
1) i thought i used it it is my bad so sorry.
2) yes thats the error code. i install this iso to 3 of my computers. they are all same. it is iso related problem. you can only test it by installing that edited iso to your system! and try to update it. or else ntlite will always have that bug. because i can't expain anything further about it.
3) yes we all hope you do that editor., as my research shows u can import a default layout via powershell. maybe ntlite can have an empty layout for us

the only problem is that idk if it permanantly locks startmenu. if it locks it then its not handy
nuhi here is new cbs, i cleared previous one and tried to update windows 2-3 times to generate new logs. maybe this helps more
Thanks, that shows an error while updating Flash.ocx.
I don't see flash removed in your preset, maybe update cleanup or manual DISM resetbase after?
If you can try and confirm without any cleanups.
Then I would like to prepare the same image, or you send that one (pre-edit) to me so I can review why would that happen and it didn't on my Turkish ISO test of your preset.

Btw make sure to use the latest version, 6962.
 

ege914

Active Member
Thanks, that shows an error while updating Flash.ocx.
I don't see flash removed in your preset, maybe update cleanup or manual DISM resetbase after?
If you can try and confirm without any cleanups.
Then I would like to prepare the same image, or you send that one (pre-edit) to me so I can review why would that happen and it didn't on my Turkish ISO test of your preset.

Btw make sure to use the latest version, 6962.
i tested on pro x64 1903 tr on 6964 ntlite beta with attached preset:

-I set cleanup to > none
-I integrated updates except the faulty one(kb4497935) to test it on same environment as before

tried installing update, it didn't gave any error, restarted pc, pc found same update again, i clicked on check updates again and it is gone. SO

- problem is SOLVED so problem was complete cleanup at update part.

and there is one more little problem: i added screenshot. basicly the problem is that red warning again. it is back. it doesnt happen on HOME version with same preset. It only happens on PRO version. and i simply dont' want to see it. can u tell me which setting causes that red warning?
and with same preset there are 2 themes

pro with warning and black theme same preset
home without any warning and white theme same preset

and i don't want to open a new thread for this so can you add an option to enable and setactive the "ultimate power plan" + can we have maybe dart support
 

Attachments

Last edited:

nuhi

NTLite developer
Staff member
Will retest your preset by Monday and fix if replicated.
Cleanup removes older versions of updates in WinSxS, but sometimes those older files need to be kept for newer version to use.
 

ege914

Active Member
Will retest your preset by Monday and fix if replicated.
Cleanup removes older versions of updates in WinSxS, but sometimes those older files need to be kept for newer version to use.
okay thank you please check on pro version and see the windows update red warning too. i know its not a bug but idk which setting controls it since it is not on home version
 

nuhi

NTLite developer
Staff member
Bit delayed due to other reports, will do this today, haven't forgot, it's second from the top.
 

nuhi

NTLite developer
Staff member
Pushed for tomorrow, got stuck with a fix prior to this one. Nothing unusual but you seem to want to know, so, there :)
Also cancelling today's release, maybe tomorrow or day after.

edit: managed to release today, tomorrow continuing on this, thanks for your patience
 
Last edited:

ege914

Active Member
Pushed for tomorrow, got stuck with a fix prior to this one. Nothing unusual but you seem to want to know, so, there :)
Also cancelling today's release, maybe tomorrow or day after.

edit: managed to release today, tomorrow continuing on this, thanks for your patience

you are simply great. thanks for the info
 

nuhi

NTLite developer
Staff member
Confirmed the flash.ocx issue, also have Settings - Apps crashing, not sure if that's a new problem or was there before.
Working on both, priority on updating.
 
Top