What the **** is TWINUI in Standard Apps and trying to change standard application closes the settings window

  • Thread starter Deleted member 763
  • Start date
nuhi

Instead of opening a new thread, I figured I'd tell you about something;

When doing a live removal of applications, they tend to stick around in the start menu, reboot doesn't fix it. It also leaves ghost buttons in Taskbar for removed applications (Edge/Store is the two that are Pinned to Taskbar at the start). This doesn't effect Offline removals, since they are not cached.

A fix for the start menu things are, I'm not sure how you'd incorporate this into the program is to go to "%LocalAppdata%\Packages" and locate Microsoft.Windows.ShellExperienceHost_XXXX or Microsoft.Windows.StartMenuExperienceHost_XXXX, and go into the folder TempState and delete the content, then just restart the "StartMenuExperienceHost.exe" or "ShellExperienceHost.exe" process. I'm just guessing, but I think the difference in what the process is called and the place the files you need to delete is located depends on the Windows version, as that's the difference between my Daily Driver and my VM. You'd have to test it for yourself.

Well this was messy, I hope you understand it though. It's not game breaking, but might be annoying to fix for people, as they can't just reboot to fix this (at least hasn't worked for me).
It didn't remove Windows Security's shortcut from the Start Menu.

After installing a CU via WU and restarting Windows 10 (because WU asked me to) Windows Security returns even though I removed it with NTLite (this also happens if I integrate a previous CU with NTLite and install a new one via WU). I used NTLite's Remove Reinstalls feature afterwards and I still have Windows Security. When I click on it even before using the Remove Reinstalls feature the Virus & threat protection doesn't show up. Even after using the Remove Reinstalls feature I can still open Windows Security and its shortcut shows up on the Start Menu as well as its icon on the taskbar. I noticed Windows Security had returned because after opening the Start Menu a new shortcut showed up with a "new" tag next to the name as well as a new icon showed up on the taskbar. How can I know if more apps and components have returned besides Windows Security? Even though no more new shortcuts show up on the Start Menu as well as new icons on the taskbar it doesn't mean more apps and components haven't return
 
Last edited:

nuhi

NTLite developer
Staff member
Would that remove shortcuts from the Start Menu which weren't removed along with the component? It's because Windows Security returns after installing a CU and even after using the Remove Reinstalls feature it still remains on the Start Menu.
As said here it will be fixed, that shortcut was confirmed when the new release was already near completion, must not destabilize it with last minute changes.
 
As said here it will be fixed, that shortcut was confirmed when the new release was already near completion, must not destabilize it with last minute changes.
It wasn't fixed in the latest version. After Windows Security was restaured I used the Remove Reinstalls feature and I can still open it (and it doesn't go to the Store like you said). When I click on Windows Security even before using the Remove Reinstalls feature the Virus & threat protection doesn't show up. Even after using the Remove Reinstalls feature Windows Security's icon shows up on the taskbar and its shortcut shows up on the Start Menu.
 
Last edited:

nuhi

NTLite developer
Staff member
It wasn't fixed in the last version. After Windows Security was restaured I used the Remove Reinstalls feature and I can still open it (and it doesn't go to the Store like you said). When I click on Windows Security even before using the Remove Reinstalls feature the Virus & threat protection doesn't show up, even after using the Remove Reinstalls feature Windows Security's icon shows up on the taskbar and on the Start Menu and I can open the app like if it hadn't been removed.
It's not yet in changelog so it's not fixed.

It is fixed in the pre-release, out beginning next week, will send it to you to stop reading about the same issues over and over.
 
It's not yet in changelog so it's not fixed.

It is fixed in the pre-release, out beginning next week, will send it to you to stop reading about the same issues over and over.
You said that although the Removed Reinstalls feature didn't remove the Windows Security's Start Menu's shortcut when opening it we got to the Store and not to the Windows Security app (which is not true) and you didn't mention we still had the apps' taskbar icon. What about these problems?
 
Last edited:
Very confusingly reported, too much work to read through.

Please summarize it in that topic what the actual issue is, no need for captain's log how the story went.
I know but I'm giving my best. Sorry to summarize it on this thread but it's better this way.

So, I did a clean Windows 10 1903 18362.1 Build Enterprise x64 pt-pt install (with KB4507453 integrated so it makes it the 18362.239 build) on the host and on a VM using Hyper-V after creating an image and I'm having some problems.

1º - After logging in for the first time on a VM the right blue network panel is empty after editing its session settings (if I don't do the latter it isn't empty). This problem doesn't happen if I do a clean install using an untouched image on a VM after doing a clean install with that image on the host.

2° - After disabling the search box the taskbar looks weird. This problem doesn't happen if I do a clean install using an untouched image both on the host and on a VM;

3º - The Advanced Startup feature doesn't show up below the Reset this PC one on a VM but oddly it shows up on the host. This problem doesn't happen if I do a clean install using an untouched image both on the host and on a VM.
 

Attachments

Last edited:

nuhi

NTLite developer
Staff member
I know but I'm giving my best.

So, I did a clean Windows 10 1903 18362.1 Build Enterprise x64 pt-pt install on the host and on a VM after using NTLite's latest version and I'm having a lot of problems.

1º - The Advanced Startup feature doesn't show up below the Reset this PC one. This doesn't happen if I do a clean install using an untouched image;

2º - When typing something's name on the Start Menu nothing shows up (although if I click on "Enter" it opens whatever I typed [if it exists, obviously] and if I type part of its name [regarding it exists, obviously] the rest shows up). This also happens if I do a clean install using an untouched image so it isn't NTLite's fault. After restarting Windows for the first time after installing it I no longer have the Start Menu problem (both on an untouched and on an edited images);

3º - Nothing happens if I copy some folders from the host to the VM (except a beep on the latter). This also happens if I do a clean install using an untouched image on the host and on a VM so it isn't NTLite's fault;

4º - After installing a CU via WU and restarting Windows 10 (because WU asked me) Windows Security (or at least its Start Menu shortcut) returns even though I removed it with NTLite (this also happens if I integrate a previous CU with NTLite and install a new one via WU). I used NTLite's Remove Reinstalls feature afterwards and I still have it (or at least its Start Menu shortcut). I noticed it because after opening the Start Menu it showed up with a "new" tag next to the name. Maybe more apps or components returned. How can I know? Even though no more apps' Start Menu shortcuts show up it doesn't mean more apps and maybe components didn't return. When I click on Windows Security even before using the Remove Reinstalls feature the Virus & threat protection doesn't show up, even after using the Remove Reinstalls feature Windows Security's icon shows up on the taskbar and I can open the app like if it hadn't been removed;

5º - I can't use Sandbox (on the host, since it looks like it's not possible to use it on a VM). It states “Windows Sandbox failed to start. Error 0x80070002. The system cannot find the file specified" (on the host, since I can't use Sandbox on a VM). This also happens if I do a clean install using an untouched image so it isn't NTLite's fault;

6° - After disabling the search box the taskbar looks weird. This doesn't happen if I do a clean install using an untouched image.

it looks like the only problem that can be fixed after doing a clean install using an untouched image is the first and the last ones.

EDIT: I can't remove modern apps' icons from the Start Menu.
Thanks, will review these on Monday and reply back.

edit: we continued here.
 
Top