Disk partition feature not working (unattended)

necronome

New Member
Hello folks,

i have got some serious trouble with the unattended feature of NTlite. I just want to wipe all available partitions and install the new system to a new partition with the maximum disk space available, regardless what is configured on the pc. Sounds easy, doesn´t it? But sadly this does not work. I have tried the following options:

1. Unattended > Configure Disk Partition > Disk Template
2. Settings: ID0 / Type GPT (UEFI) / changed the Operating System to max. size and set "0" to skip the recovery partition

With these setting i get the screen "Windows Cannot Update Computer's Boot Configuration" during the unattended setup.
Could anyone help me out of this trouble please?

best regards,
Carsten
 

nuhi

NTLite developer
Staff member
Hello Carsten,

There are no known issues with autopartitioning causing that error, while we did get a few weird reports about such an error.
Can be a normal Windows issue, or caused by autopartitioning in this case, so let's debug.

Have you confirmed the same ISO without the disk settings, all fine?
You can load the same preset and select Disk Configuration, choose Remove in the toolbar.
Boot it, and manually delete all partitions, select unpartitioned space to install.
If done, please screenshot Disk Management disk layout, to see what Windows chose.

Tried wiping the disk manually once?
See here for instructions, bit below about diskpart, take a look at the other ideas as well.
Basically boot to the disk selection (keeping it manual still), and press Shift+F10 for CMD prompt.

Is it a 4KB sector disk or which type if you know?

Let me know how it goes, if the above didn't help, send me the preset (auto saved xml, not autounattend) - if no private data can attach it here as well.

Thanks.
 

davidh

New Member
Hi there,

I have this same issue which has only appeared in the last couple of months to me. My previous set of images worked well. Now , no matter what i try I get this happening.

I will try the iso with disk wiping to ensure that is ok - but would like help in getting this work as well

Cheers
 

garlin

Moderator
Staff member
Most errors with disk partitioning are caused by mixing up MBR (Legacy) & UEFI boot modes. You can share your preset (minus any user passwords or license keys), and we can check.
 

davidh

New Member
Hi,

Target machine in this case is an older Lenovo M710q. Bios is set to UEFI only. I have attached the preset for review and appreciate your help

As an experiment I did remove the unattended disk wipe, but same issue
 

Attachments

  • Auto-saved 2d682577.xml
    6.8 KB

garlin

Moderator
Staff member
No disk layout was saved inside this preset. When you open it in Notepad, we don't see the <DiskConfiguration> XML block.
Just load this preset, and re-apply the disk layout. Save the preset again.

If you're loading an edited ISO, NTLite won't import the previous settings from Autounattend.xml. It's a known limitation.
 
Top