.NET 462 wont install on W7 Pro SP1 - Solved

Clanger

Well-Known Member
I am trying to install .net462 on a standard untouched w7 pro sp1 install. My iso is en_windows_7_professional_with_sp1_vl_build_x64_dvd_u_677791.iso with a matching file hash.

I always get the same error message, see attached. It will install if i have kb3125574 etc installed though.

I am working on 2 configurations, with 3125574 and without 3125574 and i will capture the updated image to wim file, all updates .nets c++ stuff fully integrated, no Install Pendings, so i need to have it working on both.
 

Clanger

Well-Known Member
I found a link from your link which describes the same problem and i will get a fresh 462 offline installer and try tomorrow and report, thank you :).
 

Clanger

Well-Known Member
Placed MicrosoftRootCertificateAuthority2011.cer at C:, placed cmd.exe next to it and ran as administrator - entered "CertUtil -addstore AuthRoot MicrosoftRootCertificateAuthority2011.cer" and net462 installed without problem. ahazuarus's link gave the same link as abbodi's so thank you both :).
 

Clanger

Well-Known Member
abbodi86 Is there an updated version of this file? Im having trouble running Windows Update MiniTool offline scan on w7 and it looks like the certificate and or net 4.8 are the porblem.
 

Clanger

Well-Known Member
Oh, Your w10 block for 7 and 8.1, some of the entries are missing " in some places, does that matter? The output is usually hidden so cant see successful/not messages. :)
 
Top