Component Services

MT_

Active Member
Ah these DCOM timeout/permission logs, I think they are normal and nothing to worry about.

Looks like its part of the "System" channel (System.evtx), doesn't look like it wants to be disabled with wevtutil utility. Not sure if it can be disabled at all without totally disabling event viewer.

These also occur here on my non-NTLite'd, but Live-script processed LTSC build.
But if anyone knows how to disable them from popping up to keep things clean, I'm all ears ;)
 
Last edited:

nuhi

NTLite developer
Staff member
In a sense you can use NTLite's - Settings - Event Viewer channel to disable those.
Search for COM (type in filter row) in this case, and disable all 3 or just the channel you see in the log.
 

MrWhispers

New Member
Sorry to revive a dead thread could not find any other thing on here in relation so I'm bumping this

OK so I've had a similar issue here.

I don't have DCOM+Disabled in NTLite ("Aside from WindowsSecurityCenter/Firewall/Defender") but I'm getting lots of DCOM 10016 Errors

TBH I can careless about the event logs.

What bothers me is the Application Error message " CLICK OK TO TERMINATE PROGRAM" that constantly pops up.

So far the only program installs I've seen this happen on was firefox and sabnzb

I've tried doing the registry from https://www.makeuseof.com/tag/fix-distributedcom-error-10016-windows/
This will silence the event viewer logs but I still get this Application Error Windows Notification

Things seem to be working with firefox however just the memory error pops up every time and it had a evelation error in event viewer I gave it full access and deleted the keys and the event viewer messages are silent but the app error still comes up upon app launch

error.png
How can I stop this error from happening did I strip something out with NTLite I should have not?
I had a recent issue with desktop create shrotcut feature I removed on accident had to do a Host Refresh with it checked back to fix it.
Do I need to do something for this? I don't know what is the cause so how to fix
 

MrWhispers

New Member
Had to do a Host Refresh to bring back Windows Firewall to correct the App Error's and DCOM 10016 logs.

Sorry Just woke up, Are you sauing to use Autoruns to disable the Firewall :)
 

Clanger

Well-Known Member
yeah, use autoruns to disable the firewall service, see what happens. what i like about using autoruns for tweaking is you dont have to touch the registry itself, just untick summat, use the Options below, some of them are ticked by default. if you want to see what autoruns does and where get RegFromApp(link in my essential tools link below)

New Bitmap Image.jpg
 
Last edited:

netefu

New Member
yeah, use autoruns to disable the firewall service
If we preferred disabling things over removing them we wouldn't be using NTLite.

I get this kind of error but only when I finish installing Firefox. If removing Windows Firewall (because Sphinx Firewall is mu-mu-muchh better) is the culprit , then I would guess it's the program trying to make an exception in the firewall and failing to do so. Just a wild guess tho. I never really understood event viewer.
 

Clanger

Well-Known Member
not everyone can remove certain components so my comment is aimed at those who cant remove X and autoruns is an easy way totweak and quickly and easily reverse andy changes. dont forget nuhi isnt just about removals.
if i did a fully customised install iwould have to redo it at least once a month because i find new stuff todo, and so do many users. stripping the tits out of an os is damn hard work and i dont want to do that every damn month/whatever, i gstd.
 
Last edited:

MrWhispers

New Member
I figured it out. I'm able to strip WindowsSecurityCenter/Defender, but you can't strip WinFirewall. You can disable it, but if you strip it. you get errors.

Most likely because its trying to create a firewall rule yes, I've had programs not even install or work because of it so I did a host refresh with firewall.

After I finished my install and did all my tweaks. I went in to regedit and disabled the service from starting. this leaves me with no windows firewall.

:)
 
Top