Error 183 - Impossible to unmount image

carnevale

New Member
Today when I opened NTLite it shows one of the images mounted and its impossible to un-mount
1663038421220.png

I tried:
Disable antivirus
Clean up Temp folders
Move default temp folders from default locations to new locations
Restarting the computer multiple times
Delete the location for original image
Disable 8.3 name creation
Enable 8.3 name creation

Nothing seems to help, always when I open NTLite again it shows the mounted image.

Is there any way how we can force the mounted image to be close? In this case the files were deleted and the tool still shows the image mounted.
 

carnevale

New Member
Tried using IOBit UnLocker with no-success.

Even after deleting the folder where I had the image, NTLite still shows that image is mounted.

Is there database, registry file or config that keeps state of mounted image ? It is just impossible to un-mount this image.
 

garlin

Moderator
Staff member
Channeling abbodi86's wisdom, open RegEdit and delete registry keys under this:
Code:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WIMMount\Mounted Images
 

nuhi

NTLite developer
Staff member
I just replied this over email as well.
Btw next time please Export the key for me to review first.

Added to todo an idea, I believe it's the remnant of NTFS 8.3 short names compatibility + deleting image files manually before unloading from the tool.

Of course the goal is to do this automatically, it's not like the tool cannot erase one reg key :)
The existing methods for cleaning those stuck mounts seems to have missed it, I believe due to literal comparison of NTFS short/long path.
The tool will not erase the whole key on first sign of trouble, what if there are other legit loaded images, the goal, and is usually working is to target the specific subkey that belongs to that loaded image.
 

marplo

New Member
Hello, after unexpected system shutdown during image processing my loaded image landed in an odd state.

Any action (load/unload) results in error 183 cannot create file that already exists.
Image shows as mounted, contents of mounts are in place, yet the image cannot be loaded or unloaded.

Is there a way to forget the image entirely? Been working absolutely fine before.

Tried multiple things including reinstalling the app, removing the location from settings.xml file, cleaning appdata\local\temp, running from other admin account, backed up NLTmpMnt temp folder and cleared it - all to no avail, this image seems to be now imprinted somehow in the system.

Cheers!


EDIT
removed image entries in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WIMMount\Mounted Images and problem is solved :)
 
Last edited:

nuhi

NTLite developer
Staff member
Fix released in public build 8916, it should be able to unload those images in the future.
Let me know how it goes.
Thanks.
 
Top