Features On Demand Problem - Developer Mode

filadendron

New Member
Hello everyone,

I'm using NTLite 1.8.0.7217 x64 (free license) and I am trying to integrate (to an offline image, not the live system) a Feature On Demand (FOD) - Developer Mode on a Windows 10 LTSC 1809 x64 image. (My working, live OS is also Windows 10 1809 LTSC x64).

ISO I am using is en_windows_10_enterprise_ltsc_2019_x64_dvd_5795bb03,
and the .cab for the Developer Mode is from the FOD ISO en_windows_10_features_on_demand_part_1_version_1809_updated_sept_2018_x64_dvd_a68fa301.
.cab file name is Microsoft-OneCore-DeveloperMode-Desktop-Package~31bf3856ad364e35~amd64~~.cab

When i tick Developer Mode (under Features on Demand (Capabilities)), NTLite creates 10.0.1809.x64.FOD folder in its Update folder and there is where I put the .cab for Developer Mode.
(Please note: I also add Language Features the same way and there is absolutely no problem - they integrate smoothly).
During integration process an error window pops out (Errors and warnings - Feature setup) when NTLite is unable to configure Developer Mode that says:
Operation requires missing files. Windows Developer Mode (OK and Cancel are available options).
After that, by pressing OK, NTLite successfully completes everything else and the ISO is fully usable, installs problem free (of course without the Developer Mode enabled).

Is there any solution to successfully configure/integrate Developer Mode? Or any thoughts on what I might be doing wrong?
(attached are the NTLite.log and NTLite_dism.log)

Thank you all in advance.
 

abbodi86

Member
You also need this file Microsoft-WebDriver-Package~31bf3856ad364e35~amd64~~.cab

DeveloperMode require WebDriver capability
 
Top