Multi Edition/Architecture Problems After Windows 11

crypticus

Well-Known Member
Test For Multi Edition ISO (That was working before W11 released) (I was also making dual architecture but it won't be tested in this post right now)

Environment:
NTLite 2.3.3.8568

W10 19044 x64 TR Iso Downloaded From UUP Dump
Enabled 2 Options Only; Include Updates and Integrate NetFX
Applied my "Windows 10" Preset (Tested on VM as vanilla before applying preset to see if its working)

W11 22000.434 x64 TR Iso Downloaded From UUP Dump
Enabled 2 Options Only; Include Updates and Integrate NetFX
Applied my "Windows 11" Preset (Tested on VM as vanilla before applying preset to see if its working)

-Both presets have same edits, also they copy autounattend.xml to install image. So I remove autounattend.xml from root of image before creating iso.
-Only differance in presets is, Windows 11 has TPM bypass so "setting changes" also applied to boot.wim.
-Unattend files copied to panther folder does not have any keys or edition specific settings or any partition creation info (Also attached)
-As i mentioned before, i was doing this for years without problem.

Test:
*W10 and W11 iso's created with NTLite edits were also tested before starting main tests. They both work without any issues in normal way (seperate/alone)

*When i export W10 to W11's install.wim. W10 installation fails when its reach to oobe part.
Where W11 is succesfull and sees desktop without any issues.
I'm not surprised to see W11 succeeds since every file in ISO is still its. (I will explain why this error happens at the last part of this report)

*So i tested other way around. This time i exported W11 to W10's install.wim. And now they both worked. So i assume its about boot.wim....

Result
*To create multi edition or multi architecture or both combined iso. You have to use Windows10 as a base to use its files.

*The reason i always used latest Windows (W11 in this case) as a base, was to get benefit of all the new features. But it seems from now on, if u want to create something combined you are left with W10's files, still its better than nothing.

*Also when you use W10's boot.wim you don't need TPM bypass for W11 installation.
(Having TPM bypass option even on W10 in ntlite is a good thing to have but not necessary.)



It basically says something like "Windows installation process could not be started" and when u press "okay" it restarts and gives this seccond error basically saying windows was restarted and experienced unwanted error and can't continue to installation etc etc etc.....

error1.pngerror2.png

This error happens because when you export Windows10 to Windows11, and proceed installation with Windows10 setup cannot create required partitions. After the error i returned to begining and saw this. One partition is missing. The seccond image is how it should be after normal installation.

How was it.pngHow it should be.png

This is not a bug report or something that should be fixed by nuhi, this is just an experience for others to see. Because i don't see anyone else creating multi architecture+multi edition iso rather than me. and if u try in the future i hope you see this post. If nuhi can solve the partition not creating problem at using windows11's boot.wim on windows10 installation, then yeah the problem will go away. I don't know if creating that partition via unattend.xml would help. But i won't manually create partitions and don't have experience in that arena. Everything is on default is the most healthy way for me.
 

Attachments

  • Windows 10.xml
    17 KB
  • Windows 11.xml
    16.9 KB
  • unattend.xml
    5.2 KB
Last edited:
Top