NTLite and Windows 10 22H2 Enterprise versions


New Member
Hi to all forum, I'm new and I'm sorry for my english because is not my language...
I searched on google or in the forum but I didn't find a specific answer to my issue. I've to use Win10 22h2 enterprise x64 in about 10 not too new pc for a specific software. I was thinking to buy a licence to have all ntlite options also for other iso customizations, so I tried to make a lite version of that o.s. with a free ntlite version (2.1.1 7197 portable working on windows 7 pro x64 machine). When I choose to upload the iso (dowloaded with media creation tool) and when it is completed correctly with the green dot, appears the mask with a warning message that this version of windows (enterprise) is not supported and that I cannot use all the features. I tried with Enterprise N verson but there is the same issue. I, however, went on with the next steps and many components, features and services were not editable and, at the end, the iso didn't work.
Now the questions are:
1) free ntlite 2.1.1 7197 does not support all W10 enterprise versions?
2) is it because I have to use e newer version of ntlite and in this case wich version I have to use?
3) if I buy a licence I'll be able to modify that iso without any issue?
Thaks to all.
Last edited:
Windows 7 hosts cannot fully process W8.1 or later images. This is a restriction because the DISM servicing stack which adds updates or enables optional Features, requires a later version of Windows to edit W10 images. You will have limited functionality unless you're running W10.

From W7, you can perform these NTLite actions on W10 images:
- Add or delete image editions​
- Add drivers​
- Remove components​
- Apply Unattended mode​
- Change Settings​
- Add Post-Setup tasks​

W7 host cannot handle:
- Adding Updates​
- Enabling or disabling Features on Demand​
- Adding Appx packages​
- DISM ResetBase cleanup​

To properly edit W10 images, you must run NTLite on a W10 or later system.

If you don't have a W10 system, then find a Virtual Machine like VirtualBox or VMware to run a copy of W10. NTLite can be loaded inside the VM, but runs much slower. This will allow full editing of W10 releases.

NTLite v2.1.1.7197 is from May 2021.
Ok, thanks for the advice. It's my "personal bug" use always old versions of software... I will try to follow yuor suggestions and will report here the results.
I was thinking the problem with 10 enterprise version was because i dowloaded it with media creation tool entering by command prompt the path for donwload the "medialang code it-IT" language version.
I had installed Win10 enterprise ltsc 21h2 on ssd for some tests but i had problems with Windows Defender, so that i had to deactivate it every time that ran ntlite, so i used pc with windows 7 s.o. because this kind of issue was not present.
NTLite from May 2021 isn't going to support W10 22H2 images, licensed or not. Each newer Windows release adds different changes, and you need a later NTLite to properly understand them.

If you have a "personal bug", then find a version released in late 2022.
I understand, thanks. Now i'm using 2023.11.9514 x64 NTLite free version to do some test, and at the end of my work i'll report here the results and the preset if you want to know what i do. Perhaps some user is trying to do the same thing for similar needs. My purpose is to have a version of Windows 10 22h2 as much as possible similar to Windows 7, but updated, removing all unnecessary components and functionalities. I've to use it in some pc made between 2010 and 2015 with 4 Gb ram, so my starting o.s. version is enterpriseN that is already smaller of pro or home version.
In my test in the media creation tool iso i downloaded, there are 6 versions of windows 10 (educational/educationalN, enterprise/enterpriseN, pro/proN). At the beginning of my project in NTLite i removed Edu/EduN and Pro/ProN, lefting only Enterpise/EnterpriseN.
I loaded EnterpriseN version and i made all the changes for my needs, i saved the preset, in "Apply" i didn't set (remove unnecessary versions) and at the end i created the iso and put it into a pendrive. I expected that during installation appeared the window with possible choice between Enterprise and EnterpriseN but it didn't. There was only Enterprise (with no N) version and at the end of installation i discovered that was really installed Enterpise version with neither one of the changes of saved preset.
So my question are:
- is it possible to have the normal window with the list of version to install (that one modified or the other) during installation process?
- if it is not possible to make, do i have to choice and modify only a single version?
Because before of this issue i did a test loading and modifying a single version and the changes were applied.
Thanks anyway.
I am so glad I stumbled across this. I too am trying to go from Win7 to Win11 and this info is VALUABLE. I had also planned on using 22H2. Thank you all for answering questions a lot of us have!
Last edited:
WinPE Setup will auto-select the install edition for you, when it detects:
- previously installed Windows on the boot drive​
- Windows license key in BIOS​

If there's only one edition in the image, obviously Setup has to install it regardless of what it finds on the PC.

To allow the user to choose whatever install edition they want, create a new file \sources\EI.cfg on the ISO:
Ok, thank you Garlin for the suggestion but it didn't work...
EI.cfg file is already present in sources folder but the code si different, so i replaced it with yours.
During the setup the only choice in the window was for Enterprise. At the end the s.o. installed was without any changing, meaning what Enterprise normal version. In previous tests i've made on Enterprise version, NTLite changes were applied, but in that case i loaded and selected only that version from the iso downloaded package.
Now reading what you wrote about WinPe Setup, i'm thinking that the issue is because i downloaded the iso entering generic product key for Enterprise version that is different from one for the EntepriseN version.
Now i try two test:
1) remove all other versions and load in NTLite only EnterpriseN version and apply my preset; If it doesn't work ->
2) download iso with media creation tool entering the generic product key for EnterpriseN.
I'll report the results.
Are you using AveYo's MediaCreationTool.bat? The normal Media Creation Tool (MCT) doesn't ask for a product key to download anything.
I don't support his script, but check if he creates a \sources\pid.txt with your product key. Remove it.

AveYo's script works, but don't play with the advanced options unless you're an expert. Just pick the Windows version, and do a straight download.
No, i don't know this script... The fact is that i downloaded from MS site evaluation copy of 10 Enterprise but some changes with NTLite were non supported and it (o.s.) cannot be activated, so i try to find a way to download a normal Enterprise version. Using MediaCreationTool simply clicking on exe file i was not able to choose Enterprise version, so i find a little trick to bypass this issue.
Launching MCT by command prompt as admin and writing manually the path, eula accept, retail, media arch, langcode and media edition, after UAC accept, appears the window to put the generic windows key version. According the o.s. media edition you want to download (home, pro, enpterprise, ecc.), you can find this key on MS site.
Then MCT goes on normally following his steps and at the end you have your iso file.
Following this steps last time i put key for Enterprise, and perhaps for this reason i can't manage EnterpriseN...
Now i put key for downloading EnterpriseN (the keys are different). I'll report here the results.

Well, meanwhile i can give the answer to my question #1 of last message: No, if i remove all other versions loaded in NTLite simply setting "remove unnecessary versions" and lefting only EnterpriseN, when i try to install o.s. in the window where i have to choose the version there is only Enterprise (not N) and when i click go ahead there is the message: No iso image loaded for the installation.
A mistery...
Let's go on with other tests...