Nvidia DCH Drivers

Bournesup

Member
With nvidia going forward with their new drivers the control panel now must be installed via windows store. The reason I went to the newer driver is a improved security with 496.49.

I have updated my configuration, preset attached. Windows store is working, but the nvidia control panel will not open.

I get the following error. Cannot find C:\Program Files\WindowsApps\NVIDIACorp.NVIDIAControlPanel_8.1.961.0_x64__56jybvy8sckqj\ncplui.exe filter not present. Now I updated the security descriptors for the C:\Program Files\WindowsApps folder the folder and file does exist and I can execute the file via windows explorer.

Yes, I have done exhaustive searches on the internet but this error is really non existent. Is there an additional component required that I have removed to allow for the proper opening of nvidia control panel.
 

Attachments

  • Auto-saved 0328487e_WStore_enabled.xml
    43.8 KB

garlin

Well-Known Member
Maybe the install is faulty, remove it using PowerShell (as Admin):
Remove-AppxPackage -AllUsers -Package NVIDIACorp.NVIDIAControlPanel_8.1.961.0_x64__56jybvy8sckqj

Now re-install from the Store.
 

Bournesup

Member
I did your power shell command and it did remove nvidia control panel. Then I tried reinstalling from the store and still got the same error
 

garlin

Well-Known Member
Besides the workaround to change WindowApps permissions, does your set of post-setup tweaks change any registry ownership?
It looks like the AppX package gets installed, but not provisioned (made available) for you.
 

Bournesup

Member
I do not have any post-setup tweeks that change the ownership.

The other possibility is the ownership of the windowsapp folder, which I did not change either. However I did add my user name to the list so I can view and excute files within the folder. That is how I know the folder exist as well as the file.
 

garlin

Well-Known Member
You disabled CryptSvc and have UAC\ValidateAdminCodeSignatures = 1.

That seems contradictory, with this UAC will only elevate signed code and Crypt Services checks digital signatures. NVIDIA Control Panel requires elevated privileges because you're tweaking device driver settings.

Let's try this. Remove NVCPL again. Change CryptSvc service to Automatic, reinstall NVCPL.
 

Bournesup

Member
The taskbar icon is the shortcut pin from the folder. If I click on the launch after install I get the error. If I click on the application in the start menu nothing happens.
 

crypticus

Well-Known Member
can you please tell me which GPU are you using, not every gpu's are using DCH UWP drivers. some still and will have to use legacy control panel.
 

Bournesup

Member
I cleared the store event log, after removing nvcpl. Then I reinstall the nvcpl again here are the errors

Failure invoking ms-windows-store://pdp/?productId=9NF8H0H7WMLT&ocid=&cid=&referrer=unistoreweb&scenario=click&webig=7ec2ad87-cf3d-4ea0-9dd8-2dceef645212&muid=0CA60F184E2B64C42BE21FC64FD66516&websession=&tduid=: action pdp not recognized
Error Code: Unknown HResult Error code: 0x80000000
Function: InvokeUri
Source: E:\BA\397\s\src\Core\ProtocolActions\ProtocolActionHandler.cs (109)

Exception of type 'WinStore.Identity.AuthenticationException' was thrown.
Exception Details: WinStore.Identity.AuthenticationException
Function: CreateUserIdentityFromSystemUserAndWebProviderInfo
Source: E:\BA\397\s\src\Core\Identity\TokenBrokerIdentityProvider.cs (665)

Caught authentication exception
Exception Details: WinStore.Identity.AuthenticationException
Function: UpdateStoreSessionUser
Source: E:\BA\397\s\src\Core\Identity\StoreUserProfileManager.cs (1404)

Exception of type 'WinStore.Identity.AuthenticationException' was thrown.
Exception Details: WinStore.Identity.AuthenticationException
Function: GetDefaultSystemUserAsync
Source: E:\BA\397\s\src\Core\Identity\TokenBrokerIdentityProvider.cs (607)

Error intializing default system account. Returning NULL.
Exception Details: WinStore.Identity.AuthenticationException
Function: InitializeDefaultSystemAccount
Source: E:\BA\397\s\src\Core\Identity\StoreUserProfileManager.cs (1859)
 

crypticus

Well-Known Member
I recommend you to go to safe mode and uninstall nvidia driver with DDU

after that restart and reinstall complete driver via geforce experience so it finds the proper version...

i don't think only uninstalling and installing the UWP app will fix your problem.


i had similar problem with soundblaster UWP app before. i was able to open uwp app but options were limited and unselectible. when i removed and installed driver properly my problems were fixed.


also u might consider applying these 2 reg files before installing driver
 

Attachments

  • GPU Updates.reg
    1.7 KB
  • UAC.reg
    572 bytes

Bournesup

Member
I am still using windows 10, 2009 version. I might be wrong but windows made some updates and changes to 2104 in regards to windows store. So when 21h2 is released I will do a fresh install. Meanwhile I will reset the permissions to the default state
 
Top