Post Install Office365 (Click-to-Run)

dimand

New Member
Hi All,
is there a way to have post install of Office365 Enterprise Click to Run tutorial? I tried to google around but doesn't seem to get answer.
your help is higher appreciated.
thanks
 

George King

Member
You can use YAOCTRI script for Microsoft Office 365. Then look in my Post-Setup tutorial as I added support for installing Office 365. Your Office folder on setup media should looks like this
1602663065824.png
For fully silent installation modify YAOCTRI_Installer.cmd using notepad :TheEnd section to looks like this
Code:
:TheEnd
rem echo.
rem echo Press any key to exit.
rem pause >nul
rem goto :eof
exit
So script ends after installing and Post-Setup can continue as usual
 
Last edited:

dimand

New Member
You can use YAOCTRI script for Microsoft Office 365. Then look in my Post-Setup tutorial as I added support for installing Office 365. Your Office folder on setup media should looks like this
View attachment 4016
For fully silent installation modify YAOCTRI_Installer.cmd using notepad :TheEnd section to looks like this
Code:
:TheEnd
rem echo.
rem echo Press any key to exit.
rem pause >nul
goto :eof
So script ends after installing and Post-Setup can continue as usual
Hi George,
thanks for your code, I have followed along, however I can't find where I can add this script/package to NTLite, or how to add it to have it work, I have folder look like this.
1602821937204.png
how can I add these into NTLite? are we using Post-Install?
thanks
Dimand
 

George King

Member
If you are going to use my tutorial (see my signature, it's OOBE.cmd method), you don't need to add installer into NTLite.

If you want use NTLite Post-Setup (SetupComplete.cmd method), you need to create SFX installer and then add it into Post-Setup page.

Here is quick picture driven tutorial, that can be used for every installer, that needs repack.

1602828876726.png
1602828960665.png
1602829136672.png

1602829292102.png
1602829375742.png

Optionaly add icon to your SFX - Im adding custom icon every time when repacking installers
1602829614369.png
1602829708380.png

After you created SFX installer, you are ready to add it into NTLite PostSetup page.

But remember there are some disadvantages
1) Setup needs to be extracted before installing
2) SXF need to be repacked every time, you want to update setup files inside

Hope it helps
 

Attachments

  • 1602829570551.png
    1602829570551.png
    80.3 KB
  • 1602829687052.png
    1602829687052.png
    66.2 KB
Last edited:

dimand

New Member
If you are going to use my tutorial (see my signature, it's OOBE.cmd method), you don't need to add installer into NTLite.

If you want use NTLite Post-Setup (SetupComplete.cmd method), you need to create SFX installer and then add it into Post-Setup page.

Here is quick picture driven tutorial, that can be used for every installer, that needs repack.

View attachment 4032
View attachment 4033
View attachment 4034

View attachment 4036
View attachment 4037

Optionaly add icon to your SFX - Im adding custom icon every time when repacking installers
View attachment 4039
View attachment 4041

After you created SFX installer, you are ready to add it into NTLite PostSetup page.

Bu remember there are some disadvantages
1) Setup needs to be extracted before installing
2) SXF need to be repacked every time, you want to update setup files inside

Hope it hepls
Hi Geog,
I have followed your OOBE.cmd however it was stuck in the installation of Office365, it showing that for more than 1h never move on.
1602834084533.png
Here is my files
1602834146969.png
 

George King

Member
Im going to review it and perform test now. It seems like YAOCTRI itself cannot find the INI file.. I have modded one more line and added new one in my YAOCTRI CMD installer. Will see in a moment whats wrong with it.
 

George King

Member
Figured our problem! :)

When you renamed your INI, you create mistake in that. YAOCTRI looks for C2R_*.ini but your file is C2RR_Config_x86.ini as I see it on picture you provided.

My mod in YAOCTRI itself is only related to support automatically finding right architecture for installed Windows, I will update my tutorial for that also.
 
Last edited:

George King

Member
dimand PostSetup tutorial updated, with new information due installing Office 365. I made small modification to OOBE.cmd and I also updated information about modifying YAOCTRI_Installer.cmd / YAOCTRIR_Installer.cmd to support multiarchitecture installing
 

dimand

New Member
dimand PostSetup tutorial updated, with new information due installing Office 365. I made small modification to OOBE.cmd and I also updated information about modifying YAOCTRI_Installer.cmd / YAOCTRIR_Installer.cmd to support multiarchitecture installing
Hi George, I used your latest update script but seem the error is exist, it won't find the ini again.
here is my file name
1602915270568.png
 

George King

Member
You must do something wrong. I tried now downloading latest Office files using YAOCTRI, then configured YAOCTRIR to allow installation of Office 2019 Professional Plus Retail version. And .INI eq Config files was found without problem and also Office apps are installed.
I also tested it with YAOCTRI to allow installation of Office 2019 Professional Plus Volume. Im recommending you download YAOCTRI and Office setup files again, made changes into Installer CMDs (follow tutorial) than configure needed version and add them into Office folder. It must work, I dont see any problem why it shouldn't work. If you still have problem, please provide screenshot of error. I tried it on Windows 7, but method is absolutely same as Windows 8.1 or 10.
 

dimand

New Member
You must do something wrong. I tried now downloading latest Office files using YAOCTRI, then configured YAOCTRIR to allow installation of Office 2019 Professional Plus Retail version. And .INI eq Config files was found without problem and also Office apps are installed.
I also tested it with YAOCTRI to allow installation of Office 2019 Professional Plus Volume. Im recommending you download YAOCTRI and Office setup files again, made changes into Installer CMDs (follow tutorial) than configure needed version and add them into Office folder. It must work, I dont see any problem why it shouldn't work. If you still have problem, please provide screenshot of error. I tried it on Windows 7, but method is absolutely same as Windows 8.1 or 10.
Hi George,
I might missed part of Downloading latest Office files using YAOCTRI. what I did I download the Office file by using setup.exe /download configure.xml file. and using YAOCTRIR_Generator.cmd to generate the ini file. is that correct? or How can I download by using YAOCTRI tool?
as now i still get the same error after using your latest updated files. it missing ini.
1603162246816.png
1603162326828.png
1603162364403.png


Sorry always keep you bothering, because i'm quiet new to this things..

thanks
 

Attachments

  • ConfigFiles.zip
    7.8 KB

George King

Member
You are almost done, you forgot to add _x86 into your config filename, as you are using 32bit Office. YAOCTRIR installer looks for C2R*_*%arch%.ini file with modification from tutorial to support multi-architecture. And you also want to edit AutoInstallation=False to True and DisplayLevel=True to False to fully silent installation.
 
Last edited:

dimand

New Member
You are almost done, you forgot to add _x86 into your config filename, as you are using 32bit Office. YAOCTRIR installer looks for C2R*_*%arch%.ini file with modification from tutorial to support multi-architecture. And you also want to edit AutoInstallation=False to True and DisplayLevel=True to False to fully silent installation.
Hi George,
Unfortunately it still not work, I have tried to as followed:
1. in Office folder I have Data, C2RR_Config_x86.ini, and YAOCTRIR_Installer.com
2. tried to create as your folder structure, and add all office file into x86

either way it still not work
1603265104215.png1603265053357.png
1603265077680.png
 
Top