SQL Express 2014 doesn't work with this preset

ege914

Active Member
Hi using win10 pro 1903-1909 (tested on both) fully updated with attached preset, the problem is: sql express 2014 setup doesn't work after extraction. and if i open compatibility mode for win7 it gives me this error. nuhi i need it to work for my job can u quickly test it?

edit: i tested on virtual it gave the same error. but after doing host refresh with SAME PRESET. the error is gone. so with fresh first install i get the error. after doing same preset's host refresh it works? how? so this is a ntlite bug? not a removed component problem?

btw while doing test i used all my activations on ntlite so i need my account to be reset in order to even use it on my main machine thanks. it was my fault i couldn't wait for u to test. but i think i found the problem is about ntlite, and i hope it helps


1572596326393.png

as u can see it should work on anysystem and it does normally

1572596374755.png


Download link for 2014 sql


proof that works on vanilla - so preset has problems but as i said host refresh with same preset also solves issue
1572814100016.png
 

Attachments

Last edited:

nuhi

NTLite developer
Staff member
Hi,

first I tried the preset and it couldn't install SQL Express 2014 because it was missing .NET 3.5, but the error was different than yours on the screenshot.

So I have added the .NET in the Updates page (Add - Template). Also enabled .NET 3.5 WCF under Features.
Remade ISO.

Then it passed SQL Express 2014 setup just fine.

Try not to remove Internet Explorer from Features, as that uses Windows package engine which removes too much.
Remove IE from Components, pieces that you don't need - leave HTML Viewer and Frame, 32 and 64 bit.
This should also help with the HTTP link issue you reported in a private message.

Think about SQL Express 2017 as well, maybe it doesn't need .NET 3.5.

Also avoid any other manual step outside of NTLite that wasn't reported while searching for the cause.
 

ege914

Active Member
nuhi i tested and had dif result. i think your test may be wrong?

i created a new iso 1903 pro x64 tr.
i had internet explorer-windows media player enabled in features
i did not delete any html viewer or internet explorer or edge this time
i integrated and enabled netframework3.5, and WCF was already enabled by itself when i boot the windows
i DID NOT do anything extra, i only used ntlite (i did not integrated any setupcomplete commands or reg files this time. it was all vanilla)
sql 2014 setup didn't work (i even disabled and reenabled internetexplorer and netfx3.5) it didn't help..... and after making hostrefresh with same preset, sql 2014 worked again.


i think your test environment is wrong. i think even if i don't delete anything, only acces install.wim file in ntlite, sql 2014 will act this way. and after making host refresh without any changes it will fix itself. i invite u to investigate it, because it seems it is really a bug in ntlite. here is preset u said i should do in your previous message which i did. and same result. i cant imagine how u say u got it worked out.
 

Attachments

nuhi

NTLite developer
Staff member
If I apply your preset, SQL setup doesn't even start, no error code for me.

Skipping/Resetting Settings and Services pages when making ISO made it work. I also used unattended autofil, was doubting on the "Administrator" computer name.

Now need to take a pause, will find which exact setting it is, seems like you found some Windows Setup dependency on a certain setting, probably a privacy one.

edit: and Services
 
Last edited:

ege914

Active Member
ok thank you, yes setup doesnt even show up... ı dont play with services too much, but it may be about settings tweaks part. waiting thank you for replicating issue
 

nuhi

NTLite developer
Staff member
It seems the option "Use only latest CLR (.NET version)" is the one.
Make sure not to set it until the Windows setup is done.
I'll see about delaying it, because the issue is not 100% understood why would Windows do this.
For now skip it on images if you're in a hurry.

Thanks.
 
Top