[1903] Local search broken after removing components

RSFRC

New Member
Hello, everyone. I finally bought NTLite, since I initially used it in conjunction with MSMG Toolkit to make an adequate installation of Windows 10 1803 (which I am currently using since that time). Now, I decided to switch to NTLite entirely.

I removed everything I didn't need, and tried the ISO in a virtual machine, like always. Everything I need works perfectly, except local search. There's an attached screenshot that shows what happens. I also attached the latest preset I used (though I attempted keeping Edge, keeping Internet Explorer, not using my registry tweaks, keeping LockApp, and enabling Cortana, but local search is still broken in the same way). Can some of you guys point me to the right direction to solve this? Thank you very much in advance.

EDIT: Programs and Features (via the Settings app) is broken as well. It looks like I removed too many things, but I can't seem to identify which one is responsible for this. Why does Microsoft have to make so weird relationships? I wouldn't be surprised if Paint3D was the responsible for all of this.
 

Attachments

Last edited:

martan

New Member
Apps from the Modern Settings panel (WIN+I) can be accessed.
First time it's bugged but when you go through:
System > Storage > This PC (local drive) > Apps category (it will take you there)
After this you can open it normally thought the main "Apps" category in Settings panel :D

Search - I was somehow able to re-enable it, but could not repro :( In my present I removed nearly everything.
The search seems to be bugged only in the Start menu and search box in taskbar. Explorer etc. search bar works fine...
 

RSFRC

New Member
Hmm, I usually kill Windows Update because I don't want any interruptions, but I will check that. Thanks!
 

RSFRC

New Member
Apps from the Modern Settings panel (WIN+I) can be accessed.
First time it's bugged but when you go through:
System > Storage > This PC (local drive) > Apps category (it will take you there)
After this you can open it normally thought the main "Apps" category in Settings panel :D

Search - I was somehow able to re-enable it, but could not repro :( In my present I removed nearly everything.
The search seems to be bugged only in the Start menu and search box in taskbar. Explorer etc. search bar works fine...
Hey, that worked, but after rebooting, Programs and Features crashes when trying to open it directly, requiring the workaround again. Regarding the previous problem, I enabled Windows Update, but Microsoft Store found no updates.
 

janwendt

New Member
I removed the Windows Store and Update Component with NTlite because it is bloatware i dont need. So this is no solution for me. I did not have this problem with 1809.
 
Hello, everyone. I finally bought NTLite, since I initially used it in conjunction with MSMG Toolkit to make an adequate installation of Windows 10 1803 (which I am currently using since that time). Now, I decided to switch to NTLite entirely.

I removed everything I didn't need, and tried the ISO in a virtual machine, like always. Everything I need works perfectly, except local search. There's an attached screenshot that shows what happens. I also attached the latest preset I used (though I attempted keeping Edge, keeping Internet Explorer, not using my registry tweaks, keeping LockApp, and enabling Cortana, but local search is still broken in the same way). Can some of you guys point me to the right direction to solve this? Thank you very much in advance.

EDIT: Programs and Features (via the Settings app) is broken as well. It looks like I removed too many things, but I can't seem to identify which one is responsible for this. Why does Microsoft have to make so weird relationships? I wouldn't be surprised if Paint3D was the responsible for all of this.
I too have this Start Menu search problem but after restarting the VM I no longer have it.

Hey, that worked, but after rebooting, Programs and Features crashes when trying to open it directly, requiring the workaround again. Regarding the previous problem, I enabled Windows Update, but Microsoft Store found no updates.
What do you mean by directly? By typing its name on the Start Menu?

EDIT: I don't have the Programs and Features problem. I can open it via Control Panel and the Settings app without any problem.
 
Last edited:

RSFRC

New Member
I too have this Start Menu search problem but after restarting the VM I no longer have it.



What do you mean by directly? By typing its name on the Start Menu?

EDIT: I don't have the Programs and Features problem. I can open it via Control Panel and the Settings app without any problem.
Yep, when I type something, the search returns nothing (it's empty, like in the screenshot). Search in Windows Explorer works fine, though. I might end up integrating Classic Shell.
 

nuhi

NTLite developer
Staff member
Thank you all for reporting this, it has been fixed in the next version, release tonight.

It was the Telemetry removal, 1903 changes. Also removing it after install would not have the same issue, so if you cannot wait, just keep Telemetry, then remove it after setup.
 
Thank you all for reporting this, it has been fixed in the next version, release tonight.

It was the Telemetry removal, 1903 changes. Also removing it after install would not have the same issue, so if you cannot wait, just keep Telemetry, then remove it after setup.
I didn't remove it since I don't have a license and I still had the problem. What about these problems?
 

janwendt

New Member
@nuhi I tested it with my old config and it works.
BUT i reworked it and removed further stuff i dont need. Even though i have cortana compatibility activated now i cant click into the search tray in the explorers search bar. Maybe Windows 10 User has the same problem. You can find my config attached.
 

Attachments

@nuhi I tested it with my old config and it works.
BUT i reworked it and removed further stuff i dont need. Even though i have cortana compatibility activated now i cant click into the search tray in the explorers search bar. Maybe Windows 10 User has the same problem. You can find my config attached.
Are you talking about the search box next to the Start Menu? No, I don't have that problem.
 
Last edited:

nuhi

NTLite developer
Staff member
OK, thanks to both of you. It's the usual TabletPC piece that I've been trying to filter out which Apps need it, then it turns out MS keeps changing things and makes more things dependent on it.

Will release a fix on Tuesday, if you want a pre-release, PM me, or keep one of these components:
Map Control
Sticky Notes
Tablet PC
Store
Edge
PDF Reader

@Windows 10 User, let me know if that helps in your case as well, it should.
 
Yes. When i activate it i cant click inside to search something :(
I think you have to wait for a fix.

Fixed and released build 6975, let me know how it goes.

Thanks.
Do I still have to keep Map Control and Sticky Notes? And what about these problems (except the Start Menu search one, of course, and the Sandbox one which apparently Microsoft will fix in a future CU release)?
 
Last edited:
Top