dotNet 3.5 not available

NoTRite

Member
Hey nuhi

.Net 3.5 doesn't work, even when it's enabled in NTLite. Below are screenshots. I'm also including the presets .XML file.

Thanks!

3dot5notactive.PNGattemptingtoinstall.PNGerror.PNG
 

nuhi

NTLite developer
Staff member
Hi,

thanks for reporting, will be checking on this tomorrow.
Few tips in the meantime.

Use NTLite - Source - Tools - Install Updates and pick .\sources\sxs\microsoft-windows-netfx3-ondemand-package.cab
From the full ISO, that is where the .NET 3.5 is, if online install doesn't work as in your situation.
Win10 doesn't have .NET 3.5 on the C:\Windows.

That said, the issue could be that you disabled Windows Update in Settings, not sure, will need to try your preset.
And in the future there is the Updates - Add - Templates - .NET to add it to the image directly.
 

NoTRite

Member
Hi,

thanks for reporting, will be checking on this tomorrow.
Few tips in the meantime.

Use NTLite - Source - Tools - Install Updates and pick .\sources\sxs\microsoft-windows-netfx3-ondemand-package.cab
From the full ISO, that is where the .NET 3.5 is, if online install doesn't work as in your situation.
Win10 doesn't have .NET 3.5 on the C:\Windows.

That said, the issue could be that you disabled Windows Update in Settings, not sure, will need to try your preset.
And in the future there is the Updates - Add - Templates - .NET to add it to the image directly.
Thanks Nuhi! Host refresh from the full ISO worked!

And although Windows Update has been working fine on this installation AFAIK, that wasn't the issue. The issue was that .NET 3.5 was enabled in my preset, but wasn't available in the resulting install.
 

nuhi

NTLite developer
Staff member
If the .NET 3.5 is not available or installed, use the CAB file, that is the preferred way, nothing hacky there.

The message "Operation requires missing files" does not mean it didn't work, but that it's not available.
That template is just for images, those that have the CAB on the mentioned location.
For the rest, drop the file on that page and apply.

Let me know if that helped.
 

NoTRite

Member
nuhi

I got it working by using host refresh, so my specific problem is already solved.

My point was just that this is an important bug and I hope .NET 3.5 can be fixed when making ISOs in the next release.

I thought you meant that Updates > Add > Templates > .NET was supposed to be a third option, besides host refresh or including it in the ISO, so I thought that might be another bug. If that's expected behaviour its fine.

Again, the main bug is that .NET 3.5 is not in the ISO, even when I select it in the presets.

Thanks!
 
Last edited:

nuhi

NTLite developer
Staff member
You must add .NET 3.5 as a CAB to enable it in Win10, that is normal for images.

However, that Windows Update not pulling the CAB from the net, that should work, checking.
 

Clanger

Well-Known Member
Nuhi, if i remember correctly enabling net3.5 in Features on a running system(untouched iso) tried to download it even though it was on the usb key.
 

nuhi

NTLite developer
Staff member
Nuhi, if i remember correctly enabling net3.5 in Features on a running system(untouched iso) tried to download it even though it was on the usb key.
Sure, you need to actually install the CAB as an update package.
Even then, if cumulative update is not installed after it, it might go online to pull new data, if disabled and enabled.
Adding the CAB enables it, no need to enable on the features page.
 

nuhi

NTLite developer
Staff member
Install untouched iso, install net3.5 cab, SS then CU. :)
I don't understand, what's the point of that?
We want all pre-integrated and automated.
Proper action is add all 3 (ss, cu and .net) to the Updates page and it will be automatically sorted and all done from the get-go.
 

nuhi

NTLite developer
Staff member
NoTRite, fixed .NET enabling post-setup with your preset for the next version.
Hopefully tomorrow released, depends on a few more tasks.

Shop removal was breaking the .NET enabling after setup. You can bypass that by integrating or installing the CAB directly, or keep the component until the next version.

And the service 'Microsoft Account Sign-in Assistant' should not be disabled, added this to its description.

Thanks.
 

NoTRite

Member
NoTRite, fixed .NET enabling post-setup with your preset for the next version.
Hopefully tomorrow released, depends on a few more tasks.

Shop removal was breaking the .NET enabling after setup. You can bypass that by integrating or installing the CAB directly, or keep the component until the next version.

And the service 'Microsoft Account Sign-in Assistant' should not be disabled, added this to its description.

Thanks.
Thank you nuhi! You're awesome!

Also, why shouldn't the Microsoft Account Sign-in Assistant be disabled? I don't have a MS account.
 

nuhi

NTLite developer
Staff member
Thank you nuhi! Also, why shouldn't the Microsoft Account Sign-in Assistant be disabled? I don't have a MS account.
You're welcome.

Yeah, beats me, and worst part of it is, it's enough to start the download, then you can disable the service.
I tried it all, disable MSAccount, remove it... nothing helps. So I have readded it to WU compat.
 

nuhi

NTLite developer
Staff member
Let me know if the issue is resolved for you with the build 6500+.
Thanks.
 
Top