Install Windows 7 and 8.1 onto Intel 8th, 9th and 10th(?) generation

Clanger

Well-Known Member
It will be i grant you that :) For old school i can run xp on my amd systems and 8.1. It wont be for everyone but if you dont need wmc or the latest direct x or whatever its worth a go. :)
 

Clanger

Well-Known Member
Windows 7 known working on 8th gen Pentium G5400(£57) and H310M S2V 2.0 Coffee Lake/GT 710/MX500 ssd combo. Note that this is the H310 R2 chipset as mentioned in this article. Retailers are showing Asus boards as R2.0 but not Gigabyte boards, you will have to enquire on those. They are limited to 4 sata ports but some boards have nvme connections aswell.

You should be able to use 9th gen Coffee Lake Refresh 9000 series cpus, check your bios first.

The Intel USB3 drivers for W7 must be integrated into the boot.wim(Microsoft Windows Setup) otherwise you get the missing driver window and into install.wim even if you use the usb2 ports during installation. Set CSM in bios to Enabled.
 

Attachments

Last edited:

Clanger

Well-Known Member
A very lightly tweaked w7 on i3 8300, igpu.
Handles are 1/3rd of a massively tweaked n kludged LTSC, handles i cant remember but down by 100 at least, processes down by 10 at least. Now compare those numbers to a bog standard default LTSC install.
 

Attachments

Last edited:

pmikep

Active Member
I was looking at the G5400 for the iGPU to build another computer for a video program I used to use. The program is pretty slow at encoding and won't use an external GPU. But they say that it flies with the Intel iGPU. But I can't find the 5400 on Amazon here in the States. And the next up the list jumped to $120 all of a sudden. (Also, you can't buy an AMD FX-8350 with the Wraith cooler on Amazon at this time.)
 

pmikep

Active Member
Hey Clanger, on your screen shot of Task Manager: When I first start Windows, I get a similar picture, with the CPU near zero.

But after 24 hours of so of uptime, something changes and Task Manager will start to show a few percent. It happens to me in both Win7 and Win8.1.

It might have something to do with Comodo, since I have CIS installed on both OS's. But curious if anyone else sees this behavior with Windows.
 

Clanger

Well-Known Member
G5420 is the 9th gen version. Scan doesnt, see for yourself on intel availibility. Its been like that for most of the year here :(
Prolly CIS and other stuff you kept/cant disable. The G5620 is the top dog of the pentiums, 4ghz and the UHD 630 igpu instead of the 610 in lower versions, that program of yours may respond well with the better igpu. Heres where i got my pentiums and i paid that price too :) Its listing on newegg. Amazon takes the mickey with their prices, look for a large bricks and mortar retailerbecause they have better prices, like where i got mine from.
 
Last edited:

Clanger

Well-Known Member
pmikep The G5400 is listing on amazon uk for £57, thats what i paid and its a very good price. Have a look and see if they will ship to the US after all its from 1 amazon depot to another :)
 
Last edited:

Clanger

Well-Known Member
Im not seeing any problems using the older biostar driver with hq video files in MPC BE(with MadVR). Dont do streaming except for yoopoop.
 

Clanger

Well-Known Member
pmikep Many moons ago you asked about ntlite giving an error because windows 7 had actions pending, d you remember what topic that was because i cant.
 

pmikep

Active Member
pmikep Many moons ago you asked about ntlite giving an error because windows 7 had actions pending, d you remember what topic that was because i cant.
I remember that the problem was that I had just run DiskClean and I hadn't rebooted after it finished. It was locking out files. Nuhi kinda knew that too.
 

pmikep

Active Member
Also, you might need to log in as Administrator. There was a time when NTLite had pending operations in AutoStart (or whatever) but they wouldn't run/clean up unless one booted Admin. (It seems that nuhi fixed that, because I haven't seen pending "Run Once" items in CCleaner. And I almost always boot into User account.
 

Clanger

Well-Known Member
OK. I installed one group of updates on a running system(ntlite in free mode) but the Apply button was grey on the 2nd run. Its a curated update list so their were no superseeded updates. Its a bitch having to relearn stuff. :(
 
Last edited:

Clanger

Well-Known Member
pmikep I would take this with a pinch of salt because of intels dire supply problems(at Scan at least :( ) but the G5620 is showing due on 24th september. 4GHZ 2c/4t UHD630 igpu for £92. Scans intel due dates have been a complete joke but,,,,
 
Last edited:

Clanger

Well-Known Member
Intel is releasing a H310D chipset for 10th generation. Will keep an eye open incase they give it windows 7 support like the H310C R2.0. Looks like 10th gen Pentiums and i3s may be getting ddr4 2933 ram support. Will be testing when parts availible.
 

fuji

New Member
Hey y’all - late to the party slimmin my 7’s
Not new gen but intel refreshed hardware on their NUCs for win 7 support this year, broadwell gen
In Q4 2018 and Q1 2019 two new SKUs of "Rock Canyon" - Refresh have been launched and become two of a few available models still supporting Windows* 7 (NUC5i3RYHSN and NUC5i5RYHS). These modes have updated CPU revisions and other minor changes.
 

Clanger

Well-Known Member
Windows 7 known working on,
8th generation Pentium Gold G5400(UHD 610) - Gigabyte H310M S2V 2.0 - Crucial Ballistix Sport LT Gray 8GB DDR4-2400
8th generation Core i3 8300(UHD 630) ---------- Gigabyte H310M S2V 2.0 - Crucial Ballistix Sport LT Gray 8GB DDR4-2400
9th generation Pentium Gold G5420(UHD 610) - Gigabyte H310M S2V 2.0 - Crucial Ballistix Sport LT Gray 8GB DDR4-2400 - see below

If anyone gets Windows 7 installed on any CPU H310C R2.0 and RAM combination not listed then please let me know and i will add it to the list, thank you.

Note - I am only testing hardware i buy for myself so contributions from members are welcome.
 
Last edited:

Clanger

Well-Known Member
Windows 7 Biostar iGPU driver known working on,
8th generation Pentium Gold G5400(UHD 610)
8th generation Core i3 8300(UHD 630)
9th generation Pentium Gold G5420(UHD 610) - see below

Note - I am only testing hardware i buy for myself so if anyone gets the Biostar Windows 7 iGPU driver working on anything not listed then please let me know and i will add it to the list, thank you.
 
Last edited:
Top