Unable to use RDP client on a modified 2019 LTSC

shotgunhero

New Member
Hey all,

Just as the title says, I'm unable to use RDP. All I get is "An internal error occured" and in the Event Log I get "Reason = 4". Not terribly forthcoming, but I'm sure I removed something on accident, so I'm attaching my last good preset. I could have swore I didn't miss anything, but I've got old eyes. :)

Can someone help me out?

On a secondary thread: Would it be possible to have a preset for Remote Desktop Client services in our "Compatibility" tab when doing component removals? I always have to keep a note to myself to not remove it, but I have this current issue with my removals that's baffling me.
 

Attachments

garlin

Active Member
Reason = 4 is unknown disconnect. Could be firewall issue terminating connections, or security policy not allowing TS. You didn't say if this is outbound or inbound sessions.

EAP is removed. I dunno if your remote side requires this protocol.
 
Last edited:

shotgunhero

New Member
Shouldn't. I even dropped all the firewalls in between the two endpoints, even put them on the same network.

Don't need EAP, the target and the client are on the same network.
 

garlin

Active Member
Dump your registry settings.
reg query "hklm\system\Currentcontrolset\control\terminal server"
 

garlin

Active Member
fDenyTSConnections is open on the target. Try switching the RDP network protocol, whether it's TCP vs UDP, or TCP/UDP allowed. When you say the same network is it a plain hub or switch, no fancy pants network device?
 
Last edited:

shotgunhero

New Member
Yep. Technically it's the same VLAN, as they're both on an old Cisco 3750G. Both results fail. Interestingly, other RDP clients like RoyalTS or Terminals also do not work.
 

garlin

Active Member
Guess Wireshark is your friend tonight. You might want to check if some unrelated service like SMB works. But off hand, I don't think your NTLite preset removed anything obvious.
 

garlin

Active Member
Last thought: no voodoo with jumbo frames? I saw some people complaining jumbo frames messing up MTU, and borking RDP sessions. There was a reg key to handle those cases.
 

shotgunhero

New Member
nuhi Sorry to ding you, but are there any components that can be removed that may affect the functionality of Remote Desktop? Other than the ActiveX Client of course. It appears from a WireShark dump the client is connecting, but then the connection just evaporates, which leads me to believe that a secure channel is not being established properly. Not sure if that's something in the components I could have ripped out unknowingly.

EDIT: Actually, it seems the target is sending an RST whenever I try to connect with the NTLite modified client. I'll see if I can hit it and get the same result with an unmodified client.
 
Last edited:

Kasual

Well-Known Member
Keep all network related stuff in Network.

I don't use RDP but seems like you are removing too much there.
 

shotgunhero

New Member
Sorry if this is the wrong forum! o_O Yeah. Fortunately the computer I'm working with is a CF-19 so I can change out the hard drive quickly. I had an idea about seeing if I could find a few DLLs that I know RDP needs to work.
 
Quick suggestion: try keeping remotefx, in case you removed it.

Fil

Sorry if this is the wrong forum! o_O Yeah. Fortunately the computer I'm working with is a CF-19 so I can change out the hard drive quickly. I had an idea about seeing if I could find a few DLLs that I know RDP needs to work.
 

shotgunhero

New Member
I kept RemoteFX in my installation. I kept both Remote Desktop Server and Remote Desktop ActiveX Client, as a matter of fact, I just checked.
 

shotgunhero

New Member
A clean host is now doing it too. So, I think it's safe to say it's a configuration issue on the OS rather than the removal. So, I shall sort through it.
 

nuhi

NTLite developer
Staff member
A clean host is now doing it too. So, I think it's safe to say it's a configuration issue on the OS rather than the removal. So, I shall sort through it.
I was just about to test this report.

Please keep me updated, if there is anything I should be testing for.
Meaning, if you have an issue with Windows itself, of course Google is your friend. However, if you only have the issue when using certain settings in NTLite, then please provide that latest settings-only preset and I'll pick up from there.

Thanks.
 
Top