Install Windows 7 & 8.1 on Intel 8th, 9th, and 10th generation - Closed

do you get that error when you reinstall the OS the laptop came with? your machine is ice lake 10th gen and installing 7 and 8.1 can be a hit or miss affair on newer hardware. my bet is the manufacturer has locked your machine to w10 and you are gonna be FoL getting 8.1 on it.
It came with Windows 10 and reinstalling Windows 10 seems fine. It's an Asus Vivobook X403JA. It looks like I'm out of luck with 7 or 8.1 but thanks for the reply anyway!
give ltsc 1809 a try. what build did it come with? eg 1809 etc
even if you did manage to get 8.1 on it you might not be able to find all the required drivers.
solved a windows 8.1 capture issue, will have another go with i3 10105F/B560 today.
Last edited:
windows 8.1 working on i3 10105F/B560. see post no 157.


but there are 2 missing drivers not in SDI, Intel Lan(as expected)

New Bitmap Image.jpg

and a chipset driver which may or may not affect OS stability in the long term.
Last edited:
Intel ME is only required for enterprise level access (that is what the Simple communications controller usually is). There's an intel Null_Heci driver compatible with most of them, which is basically 'don't bug me, you don't need this driver to function' message for the OS.

The main problem is that intel has been embedding telemetry at driver and hardware level these days, and using Management Engine (which also control certain booth operations and power configs) to do unwanted things if its disabled. Since it is a remote access and even kill switch for a machine, there has been attempts to disable it in linux space, of which coreboot is reportedly successful.
it could be IME. that setup is still all connected, i can go through it and have a proper look. i know i use the ME driver only with 8/9th gen w8 and 8.1. i'll look tonight or tomorrow.
i suppose the next logical step is getting w10 working on intel 12th gen/+ cpus that have Big Cores only.
Last edited:
I am slightly suspiscious (hahaha, sarcasm on the 'slighly' BTW), that this is a deliberate ploy of M$ to force people to abandon the telemetry-lite OSs like Windows 8.1 and 7.

It doesn't help that if you look at it objectively, it took 2 gens (from Intel Skylake to Coffee Lake) to actually produce some improvement and make people want to abandon SKL systems and Windows 8.1 full compatibility, and now 4 gens (mysterisouly coinciding with Win11 launch, huh? Interesting, Interesting...) to again make noticeable improvement that make people want to migrate again.

Not me. I'm staying on my Coffee Lake Refresh Notebook, Windows 10 Lite (Soon to be LTSC, even though Miracast stopped working and refuses to work again) unless I can actually make windows 11 functional and airgapped. (And using a DNS resolver with log function I can tell my PC is more tightly airgapped than my TV!)
its not IME, tried installing heci driver. modded inf as per CEW s link to canonkong at winraid(for the intel lan driver), wont install. there are a f-ton of intel inf,s in the pack, dont know which one to mod.

Time to call it a day at last. im not willing to go any further.
Clanger, I'd be happy to have your advice on my issue.
Set of events (I'll skip unnecessary details):
1. Old PC with Windows 7.
2. Bought and assembled new PC: motherboard "ASUS TUF GAMING B560M-PLUS WIFI" with (obviously) B560 chipset, CPU Intel 11th gen, RAM, PSU.
3. Installed SSD from old PC with Windows 7 and old GPU into new PC.

New PC with old Windows 7 is able to boot (eventually), but... keyboard and mouse (wireless, USB receiver and separately wired) does not work and it seems USB in general does not work.

What do we have:
  • USB mouse/KB wireless and USB KB wired works well in BIOS and in Windows boot menu (where you can choose safe/normal mode). Moreover, USB stick with led indicator blinks (which also shows that USB ports work).
  • Motherboard has 4x USB 2.0 and 4x USB 3.2 and 2 extended ports with USB to connect to front panel USB ports - none of those works under Windows 7 (not mouse/kb wired/wireless, no blinking on USB stick).
  • Motherboard has no PS/2 to connect old style mouse/kb to check.
  • No PCI (though there's 1x PCI-E).
  • On ASUS official site there's no drivers for Win7, only for 10/11.
  • I still can easily switch to old HW (and Win7 works well) and back to new HW within 10-15 minutes, so I can do some actions, but with old motherboard being active.
What I want to avoid:
  • Updaing Windows to 8/10/11
  • Re-installing Windows 7
It seems that I need to install/inject some drivers for USB or at least somehow collect info what devices don't have drivers when Win7 boots on new HW to understand at least something.

Your help is highly appreciated.

P.S. I assume USB won't be the last problem I'll have with drivers.
lunatic those problems are as expected and experienced first hand :(. You got less than 1% chance of getting w7 on 10/11th gen.
You "might might might" get 7 on there, look around mdl and win-raid, but i very much doubt it.
I did get 8.1 on, but with caveats, read back a bit.

To be totally honest just put w10 on it and tweak/do removals.
Clanger, hey, you are too pessimistic :)
> read back a bit
I read everything from page 6.
> To be totally honest just put w10 on it and tweak/do removals.
I'll do, eventually :( but first I'd like to use in on Win7 and see how many problems are there. If it's only about USB and I'll find a way out - I'll stick to Win7 for a while, if there are lots of problems - will install a separate SSD and separate Win10 and will port my stuff gradually within month or so.

So, what I'm thinking about to be able at least to gain control over Win7 on new HW:
  • Should PCI-E to USB work without drivers?
  • Am I right assuming that mobo doesn't care what is behind this PCI-E, whether it's USB or PS/2 or something else?
Give it a go by all means, maybe i missed something or missed a trick, i dont know. All i do know is i had spent a lot of time effort and money on b560 and got nowhere with w7.

What the problem is i dont know. I couldnt get past the setup language selection page. No kb or rodent.
Last edited:
damn ok I will help I did this a while back when I was on ryzen 3600, you have to manually add the usb drivers to the windows 7 iso and keyboard and mouse works and isnt disabled, this I will work on and come back with what Ive been able to figure out and guide you guys thru it, I figure I did it once before so I should be able to do it again, last time I tried Im sure I had just downloaded bad usb 3 drivers and gave up after one try of it not working on my intel 10600k