GamerOS Windows 10 & 11 DIY Preset

D

Deleted member 8142

Guest
Final GamerOS Presets, I dont think there is any more to discover at least for my purpose, many thanks and hopefully this is it, when stuff changes I'll update them
Great Going. Pl Keep it up :)
 

zxctop1

New Member
I managed to make a really stripped down epic games / steam compatible preset with everything working fine. Be carefull to change the region to your wishes because it's on the azerty layount and french input since i'm french. You will have .exe error messages but they work just fine. Managed to get over 1250 fps stable on fortnite, performance mode, with a r7 5800x an a 3060 ti. Hope it is usefull

Consider installing classic shell as windows search is broke aswell (win+r still work fine)
21h1?
 

Taosd

Active Member

bruh, 21h1 what ?

was it created using w10 21h1 ? check the preset and you will find it was

or do you mean is it for w10 21h1 ? again, check the preset and you will find that it is.

and please, a friendly word of advice, if my first post was similar to yours, it doesnt make sense. it would be as if i just posted 'windows?' , please be more elaborate in the questions.

Layn good looking preset, appreciate the work put into it
 

zxctop1

New Member
bruh, 21h1 what ?

was it created using w10 21h1 ? check the preset and you will find it was

or do you mean is it for w10 21h1 ? again, check the preset and you will find that it is.

and please, a friendly word of advice, if my first post was similar to yours, it doesnt make sense. it would be as if i just posted 'windows?' , please be more elaborate in the questions.

Layn good looking preset, appreciate the work put into it
on 1809 my Windows does not load, that's why I ask for which version of Windows this xml is made
 

Clanger

Moderator
Staff member
While not a gamer build, Clanger's LTSC 1809(17763) project page is a start.
Not really. I posted an LTSC 1809 preset for JamessJ and while its limited it works perfectly. I am updating it for current LCU build and a captured image but ive still got V2 somewhere and can post it if required.

Edit - updated to v5, built on 17763.2114 captured wim.

There's recent threads debating whether 1809 users should upgrade to 20H2, instead of staying back.
It depends, gamers should use latest builds as per recent discussions(somewhere here), with JamessJ i think, but if you are not a a gamer and want a mature os with a longer shelf liffe then 1809 ltsc is ok. LTSC 21 isnt mature enough yet in my opinion, an os needs 2 years out in the wild before i can call something mature. Besides, forums will have picked something to pieces by then and know all the quirks/pitfalls etc and found solutions.
 
Last edited:

Txmmy

Active Member
just found an error in rust, with this preset, cannot write to memory error or something like that when trying to load a map, if anyone knows what this could be it would save time, but Ill be slowly stripping stuff out until I can cause the error and see if I can find what causes it
 

Txmmy

Active Member
is that a question or are you suggesting to not remove drivers?, i have removed filter drivers and such
 

Taosd

Active Member
is that a question or are you suggesting to not remove drivers?, i have removed filter drivers and such

Txmmy are you sure it is the preset and not rust itself. i have been reading through a few things and a few people have had if not this, then a similar issue. apparently trying in admin mode could fix, if not then another suggestion given was roll back gpu drivers.

wish i could help further but currently dont have the game m8
 

Txmmy

Active Member
OK that makes sense taosd, yeah i just tried leaving the driver stuff alone and its working so far, but i will test and see if it was the cause, and when i discovered error i was admin as i was using autounattended and setup like that, and i thought that could have been issue so i tried reg without admin and such, so i will try some further testing just to make sure
 

kiczkabog

New Member
200 drivers removed (with infrared devices) - no problem. E.G. If you remove Modem you should remove modem drivers also. And I recommend to make two versions of preset: Store and Game, because a lot of people want to use MS Store or Xbox.
 

Txmmy

Active Member
yeah the drivers are left there for compatibility and its kinda not worth removing cause they arent even the bulk of the iso, and saves from having issues in the future so hardware tab is all i need to mess with, and this preset is meant for steam games, not ms store or xbox games, no offense I just think thats going backwards, and im sure that there is some way to install apps and use the xbox functions if one were so inclined to do so
 

garlin

Moderator
Staff member
yeah the drivers are left there for compatibility and its kinda not worth removing cause they arent even the bulk of the iso, and saves from having issues in the future so hardware tab is all i need to mess with, and this preset is meant for steam games, not ms store or xbox games, no offense I just think thats going backwards, and im sure that there is some way to install apps and use the xbox functions if one were so inclined to do so
If you preserve UWP (Store app) compatibility by keeping Appx UX, .NET 2.2, VCLib, Xaml -- then users can sideload.
 

evolve

Member
thanks for the preset :) I just start testing it on ltsc 2021 don't know why the event viewer service is not started maybe its a bug or something the error is: Error 4201: The instance name passed was not recognized as valid by a WMI data provider.
also on the internet, every link I found said delete - rename and get the ownership of the folder etc... of C:\Windows\System32\LogFiles\WMI\RtBackup and restart your pc but it's just not working
 

garlin

Moderator
Staff member
thanks for the preset :) I just start testing it on ltsc 2021 don't know why the event viewer service is not started maybe its a bug or something the error is: Error 4201: The instance name passed was not recognized as valid by a WMI data provider.
also on the internet, every link I found said delete - rename and get the ownership of the folder etc... of C:\Windows\System32\LogFiles\WMI\RtBackup and restart your pc but it's just not working
Instead of taking ownership, can you try this as Administrator? sfc /scannow
It's possible Windows update is having conflicts with the mods, and messing up the ACL's.
 

Txmmy

Active Member
idk, i dont know how different ltsc is from pro, have i removed event viewer? ive literally just combined the privacy, gaming and then lite templates and then fixed any error, i got after doing such so that backup and stuff works, im still struggling with this build myself, cause if i remove windows updates then cant install framework 3.5 and such so im just trying to think of to try next, maybe i'll leave windows update alone and just turn it off on post setup also it seems rust fails, but im sure thats got something to do with windows media player, cause i can rip everything out and rust still works, but if i touch media player at all rust crashes on loading map, and yet media player is removed with the gaming template so idk what to think
 

evolve

Member
Instead of taking ownership, can you try this as Administrator? sfc /scannow
It's possible Windows update is having conflicts with the mods, and messing up the ACL's.
thanks, unfortunately, it didn't help one thing weirdly happened I used the windows repair tool by tweaking and selected reset services permissions and repair wmi after restart it started working for like a minute then I closed and opened it again it disabled the service and returned the same error! I did that again but this time there wasn't even 1 minute of working :oops:

idk, i dont know how different ltsc is from pro, have i removed event viewer? ive literally just combined the privacy, gaming and then lite templates and then fixed any error, i got after doing such so that backup and stuff works, im still struggling with this build myself, cause if i remove windows updates then cant install framework 3.5 and such so im just trying to think of to try next, maybe i'll leave windows update alone and just turn it off on post setup also it seems rust fails, but im sure thats got something to do with windows media player, cause i can rip everything out and rust still works, but if i touch media player at all rust crashes on loading map, and yet media player is removed with the gaming template so idk what to think
I don't think so there was changes in event viewer channels i don't think that's the real problem tho I need to waste more time on it I guess :rolleyes:
wants to append mt profile with this profile don't think its gonna break it

even though it's looking very odd but if disabling WU is gonna be ok I think it's better to not waste time on it
btw maybe there are hidden problems that can reveal after a while in different things.
 
Top