My ISO stops loading in mid-Setup after using DISM Compatible Updates Deletion! (MSMG)

RobertX

Member
On NTLite, I updated my ISO and used the DISM Compatible method to delete old updates.

Then, I made exported three different parts of the install.wim file.

Then, for each part, on MSMG Toolkit, I placed a registry key for each part.

I re-wiped, reinstalled the ISO, and on the "Just a moment..." screen, nothing's happening!

What's wrong?

I am using the current version of NTLite as of time of writing.
 
Skip MSMG and try fresh just NTLite when reporting, otherwise it's unclear what to test.

It is not expected, known possible causes might be:
- disabled some services that are needed for Windows setup
- added installers in Post-setup Machine entries that require user input, prompts are not supported then so it waits

Save preset used, for me to replicate.
If the issue is not there without MSMG, then vice-versa, try it without NTLite, and if it still fails, report to them instead.
Separate the causes, see which one is it and how, for devs to find the issue.
 
But that's the thing,I can't exclude MSMG.

I use MSMG because I can't assign different sets of registry keys to each individual part of the install.wim file in NTLite.
 
Last edited:
But that's the thing,I can't exclude MSMG.

I use MSMG because I can't assign different sets of registry keys to each individual part of the install.wim file in NTLite.
2 things:
- I cannot fix MSMG, so first make sure that it is not the cause of the issue (see my reply above)
- You can add registry entries via NTLite with the REG files, add it to Integrate - Registry
To propagate any actions to multiple editions, use Apply - Reapply to other editions tree.
 
In the past, I never had any trouble with using NTLite in tandem with MSMG. The troubles began when I started to clean out the updates using DISM Compatbile and DISM Resetbase each in different tries.

Before that, I was able to add the registry keys using MSMG toolkit and integrate updates using NTLite. Never had a problem, that is, until I discovered that my images were too fat. Then I started to wash away old, redundant updates.
 
Last edited:
Do you have examples of these reg files? Without a working sample, it's hard to understand why it works/doesn't.

Admittedly, the NTLite way of automating different registry files for each image is less than ideal. It requires creating a blank preset (with no other mods), and Adding a reg file under Registry as a placeholder. Then clone that template, and edit each preset copy with a different named reg file.

You would batch script a series of NTLite runs:
Code:
NTLite.exe /LoadImage:"\path\to\install.wim" /ImageIndex:1 /LoadPreset:"preset1" /ExitAfter:1
NTLite.exe /LoadImage:"\path\to\install.wim" /ImageIndex:2 /LoadPreset:"preset2" /ExitAfter:1
NTLite.exe /LoadImage:"\path\to\install.wim" /ImageIndex:3 /LoadPreset:"preset3"

NTLite.exe /? (for help)
 
When you say examples, what do you mean? Do you want me to upload them?

If so, I'll attach them.

SetupComplete.cmd works as follows:
Mod Note - Removed due to references to kms activators.

In any case, as I said, the troubles began when I attempted to clean out the older updates, which I think is the most important thing in this problem. That's when the problem started. I don't think the method of adding registry keys regarding the method of doing so it is important; I've done it before with MSMG and nothing problematic came out of it. It was when I tried to erase the older updates (DISM-Compatible and DISM-Resetbase) that the thing acted up.

Is it dangerous to do such a thing?
 

Attachments

Last edited by a moderator:
That's your problem - Resetbase, as Windows f---s up monthly updates and you can do a reinstall. W11 needs all files for installation - even the not installed in SxS folder - which is not present with Resetbase + MS released an OObe update resently, which proberly would be needed in your scenario or just cut MSMG. BTW, you havn't attached a preset for your build?
 
Last edited:
And as suggested already - get rid of MSMG. And don't forget to attach a preset if regarding NTL trouble. Thanks.
 
I know, I'm not actually.

What I'm discussing is that the registry keys will dictate a different response when thrown, think of it as that.

We can leave activators out of this, and maybe replace the conversation with, say, I don't know, printing out a response, or even just any other action than activators.

The issue is not with the activators, the issue is with why Windows would just stop at "Just a moment."

If you want to explore the activators issue, I don't use activators, I have a legit key. I just included activators for fun. I don't use them at all, I swear.

Now let's get back to the conversation.

EDIT: And francis11, I also tried DISM Compatible to wipe updates, didn't help.
 
Your SetupComplete.cmd script isn't code-safe.
Code:
if %state%==BLAH (
    fltmc >nul || exit /b
    call "%~dp0script.cmd" /args
)

If ftlmc returned an error, exit /b aborts the entire script – skipping over SetupComplete's self-cleanup lines.

If you manually created SetupComplete without using NTLite, this isn't a problem. A recent NTLite change allows SetupComplete to work on BIOS-licensed PC's (where it's never worked before, per MS design), making this distinction important because the script may be called twice, if the first-run instance doesn't end with a self-removal. This is moot if you're running on a non-OEM PC (not Dell, HP, Lenovo).

I have no idea if that's happening, but whenever you're stuck at "Just a moment", it's typically related to Post-Setup commands. DISM corruption to WinSxS backups doesn't induce this behavior.

As we've said before, start with a clean ISO and only use NTLite to apply Updates, DISM ResetBase, and install without Post-Setup commands. If you're truthful that the only reg changes are for self-identifying each image, those aren't reg edits aren't the root cause. Presuming this test case doesn't install, then provide us a preset so it can be duplicated by testing.
 
OK, Clanger will be mad about this post, but I did make an edition where the if statements cannot touch: "Use your own licence key."

For that, I did not include an if statement nor did I forward a registry key. I know that I might be banned for elaborating, so I'll just say this: I usually choose that edition, and still it freezes.

EDIT: Sorry I didn't bring this up, I actually forgot.
 
Last edited:
On that note, I'll do this again and, this time, I'll include the presets.
OK, I'll make sure to go over the steps as it touches a design choice that needs review.
Best would be to send me a DM with the uploaded prepared image (don't share publicly), before NTLite edit, with a preset aside that breaks it.
That would speed up the testing and fixing if needed, and you can do whatever you want to the image before that.
 
Do you want the image (i.e. ISO) with all the updates are applied, the older ones erased, and the registry keys applied, done all in NTLite?

I remembered that you want me to not use MSMG Toolkit.

Then I shall, but PM me to tell me how to upload a big file like the ISO.

OK, thank you.
 
Last edited:
Back
Top